1 Reply Latest reply: Jul 14, 2014 8:39 AM by userBDBDMS-Oracle RSS

    Linux, want DB_PRIVATE off

    user4374420

      How can I get DB_PRIVATE to stop being on by default?

       

      I've built db-5.3.21 under Linux, but I don't want the DB_PRIVATE flag to be on for every database I create (eg, db_hotbackup complains).  I configure with

       

         cd build_unix

         env CC=gcc ../dist/configure --prefix=/usr/local

       

      The leads I have so far suggest calling configure with

       

         --disable-posixmutexes            OR

         --with-mutex=x86_64/gcc-assembly

       

      but neither one caused DB_PRIVATE to go away as a default.

       

      Does anyone know how to fix this?  Is it likely a LD_LIBRARY_PATH problem?

       

      Platforms//Filesystems tried:

         RedHat Linux 2.6.32-431.17.1.el6.x86_64 x86_64 // fstype xfs (rw,inode64)

         SUSE Linux 3.0.82-0.7-default x86_64 // fstype reiserfs (rw,acl,user_xattr)