2 Replies Latest reply on Aug 21, 2014 11:44 PM by Luz Mestre-Oracle

    jdbc oci driver configuration on weblogic

    user13544105

      Hi guys,

       

      I am trying to configure OCI driver(type 2 driver) on my weblogic 11g installation on my windows 64 bit machine. Below are the steps I followed to achieve a new connection from weblogic admin console-

       

      1) Set ojdbc6.jar and orai18n.jar to class path in commEnv.cmd file. Also tried adding these jars to weblogic_installation/domains/lib directory.

      2) Logged into weblogic admin console and tried to create a new connection under data sources -> new generic data source - >data base driver=other -> driver class=oracle.jdbc.driver.OracleDriver, uri=jdbc:oracle:oci:@lnxdb-pts-vm-128-vip.mydomain.com:1545/testDB

       

      With the above specified setup, I am getting the error as- java.lang.UnsatisfiedLinkError: oracle.jdbc.driver.T2CConnection.getLibraryVersionNumber()I

       

      I tried to add oraociei11.dll file to server/lib directory of weblogic installation and tried different versions of ojdbc6.jar. I am using oracle 11g(11.2 v) db client. So tried using ojdbc6.jar available under the db. But still no luck. I always get the same error stated above.

       

      How can I get this error resolved. Thanks in advance.

       

      Regards,

      kumarjee Alluri