2 Replies Latest reply on Mar 18, 2015 6:35 PM by user2101190

    sqlldr cannot start because oranfsodm12.dll is missing


      Hi, Oracle Experts


      sqlldr gave error when I tried to run it.





      OS: Win7 64bit

      "Oracle Database Client" I used is from this page: Oracle Database 12c Release 1 ( for Microsoft Windows (x64)

           (Scroll down on that page, I use "Oracle Database Client ( for Microsoft Windows (32-bit)". Tried x64 version client. It gave same error message.)


      After hours searching online, I found this link that might be temporary solution: [Oracle] Fichier oranfsodm12.dll absent du package client ,  Blog de Jérémy Jeanson (The page is in French. Here is the link translated by Google https://translate.google.com/translate?sl=auto&tl=en&js=y&prev=_t&hl=en&ie=UTF-8&u=http%3A%2F%2Fblogs.codes-sources.com%2Fjeremyjeanson%2Farchive%2F2014%2F11%2F10%2Foracle-fichier-oranfsodm12-dll-absent-du-package-client.aspx&edit-text=)


      It suggests that, in bin folder, copying oraodm12.dll and renaming it to oranfsodm12.dll could be a fix. I tried, that works for me so far.

      Does any have any other suggestion? It seems a bug in this version "Oracle Client", if any one has the link for other version of Oracle Database Client (which comes with sqlldr utility), please provide. I will appreciate it.