5 Replies Latest reply on Nov 19, 2015 12:54 PM by Pierre Timmermans

    Analysis charts not working in OBIEE12c

    Pierre Timmermans

      I have some blocking problems with OBIEE 12c, I am wondering if other people also have issues. I did a default install of OBIEE on a Linux box, it went ok but it was incredibly slow. Starting weblogic and the node manager is also incredibly slow. Maybe I should try another install on a bigger machine ?


      The first problem is with analysis, I can make the analysis and create a view of type chart but the chart is not being displayed


      In google chrome, I see this stack trace


      DVTChartView::handleOnDemandLoadHtml5Chart: Cannot read property 'length' of undefined

      TypeError: Cannot read property 'length' of undefined

          at DvtGraphCore._bringScrollbarsToFront (http://evs-r-ora08.bebr.evs.tv:9502/analytics/res/v-0YH2UYTNo3k/b_mozilla/views/dvtchart/lib/dvt/html5/html5libloaderutil.js:1:686563)

          at DvtGraphCore.render (http://evs-r-ora08.bebr.evs.tv:9502/analytics/res/v-0YH2UYTNo3k/b_mozilla/views/dvtchart/lib/dvt/html5/html5libloaderutil.js:1:677544)

          at DvtGraph._startBlackboxAnimation (http://evs-r-ora08.bebr.evs.tv:9502/analytics/res/v-0YH2UYTNo3k/b_mozilla/views/dvtchart/lib/dvt/html5/html5libloaderutil.js:1:707400)

          at DvtGraph.setXML (http://evs-r-ora08.bebr.evs.tv:9502/analytics/res/v-0YH2UYTNo3k/b_mozilla/views/dvtchart/lib/dvt/html5/html5libloaderutil.js:1:706377)

          at DvtStandaloneGraph.setXML (http://evs-r-ora08.bebr.evs.tv:9502/analytics/res/v-0YH2UYTNo3k/b_mozilla/views/dvtchart/lib/dvt/html5/html5libloaderutil.js:1:934577)

          at HTML5Chart.renderChart (http://evs-r-ora08.bebr.evs.tv:9502/analytics/res/v-0YH2UYTNo3k/b_mozilla/views/dvtchart/rendering/html5/html5chart.js:1:2890)

          at DVTChartView.handleOnDemandLoadHtml5Chart (http://evs-r-ora08.bebr.evs.tv:9502/analytics/res/v-0YH2UYTNo3k/b_mozilla/views/dvtchart/chartview.js:1:21036)

          at obips.Callback.exec (http://evs-r-ora08.bebr.evs.tv:9502/analytics/res/v-0YH2UYTNo3k/b_mozilla/common/obips.JavaScriptExtensions.js:1:3938)

          at c._onResourcesAdded (http://evs-r-ora08.bebr.evs.tv:9502/analytics/res/v-0YH2UYTNo3k/b_mozilla/common/ondemandload.js:1:2916)

          at obips.Callback.exec (http://evs-r-ora08.bebr.evs.tv:9502/analytics/res/v-0YH2UYTNo3k/b_mozilla/common/obips.JavaScriptExtensions.js:1:3938)


      In Firefox, I get a popup windows with this message : Fatal, response must be in plain text format.



      The second problem is with visual analyzer, any vizualization of type chart works but I cannot make table or pivot table visualization, I get a different error


      Error: Handling BIPS view html request failed.: Script error for: ImportMeFirst





      It could be caused by a timeout because it hangs a bit before throwing this error


      Any suggestions is welcome, I am also curious to know if other people have issues with OBIEE 12 or not


      Thanks and regards,



        • 1. Re: Analysis charts not working in OBIEE12c
          Pierre Timmermans

          I de-installed and then re-installed OBIEE 12 (I also gave some more CPU's and installed the vmware tools), and now it is working :-). The install procedure is very smooth.


          I believe that I installed the soft. when the hostname was <something>.localdomain but then later removed the localdomain, this could have caused the various strange issues.

          • 2. Re: Analysis charts not working in OBIEE12c

            Dear All,


            I'm facing the same issue.
            I've installed, OBI12c in Linux 6.

            While opening different charts in Analytics, I'm getting the error "Fatal: Response must be plain text format" when opening in Mozilla browser and getting a empty chart.

            I tried opening in chrome and same empty chart is displayed without any error.
            Kindly share, if anyone faced this issue and got solution..

            Hi Pierre,

            Whether re-installing is the only solution or is there any other without re-installing? 

            • 3. Re: Analysis charts not working in OBIEE12c
              Pierre Timmermans

              In the server log file <DOMAIN_HOME>/servers/obips1/logs/sawlog0.log there is a stack trace. So it is very likely a bug


              Actually the original error was different for me, then I re-installed which solved the problem but then it re-appeared. Because I am running on a very small server, I re-installed yet another time but now on a physical machine. Problem seems to be solved. I could not fix that without re-install.


              Here is the stack trace. I am afraid only oracle support can help but I don't have the possibility to log a call in metalink




              [2015-11-18T12:38:57+01:00] [OBIPS] [ERROR:10] [] [saw.charts.cache.processchart.error] [ecid: 0aa6e588-9339-4e6b-881b-0dc6df1d10b3-000044a0,0:1:3] [tid: 1526904576] [SI-Name: ] [IDD-Name: ] [IDD-GUID: ] [userId: ] A fatal error occurred while processing the request. The server responded with: oracle.bi.nanserver.fwk.exception.BISvsException: A system error has occurred. Please contact your administrator..[[









              [oracle@evs-r-ora08 logs]$ vi sawlog0.log

              oracle.bi.nanserver.fwk.exception.BISvsException: oracle.bi.nanserver.fwk.exception.BISvsException: A system error has occurred. Please contact your administrator.

                      at com.siebel.analytics.web.javahostrpccalls.dvt.DVTChartRpcCall.processMessageInternal(DVTChartRpcCall.java:262)

                      at com.siebel.analytics.javahost.AbstractRpcCall.processMessage(AbstractRpcCall.java:251)

                      at com.siebel.analytics.javahost.MessageProcessorImpl.processMessage(MessageProcessorImpl.java:200)

                      at com.siebel.analytics.javahost.Listener$Job.run(Listener.java:223)

                      at com.siebel.analytics.javahost.standalone.SAJobManagerImpl.threadMain(SAJobManagerImpl.java:207)

                      at com.siebel.analytics.javahost.standalone.SAJobManagerImpl$1.run(SAJobManagerImpl.java:155)

                      at java.lang.Thread.run(Thread.java:745)

              Caused by: oracle.bi.nanserver.fwk.exception.BISvsException: A system error has occurred. Please contact your administrator.

                      at oracle.bi.nanserver.fwk.message.FwkMessage.throwGenericFwkError(FwkMessage.java:91)

                      at oracle.bi.nanserver.fwk.service.BISvsProxy.invoke(BISvsProxy.java:86)

                      at com.sun.proxy.$Proxy11.generateView(Unknown Source)

                      at com.siebel.analytics.web.javahostrpccalls.dvt.DVTChartRpcCall.processMessageInternal(DVTChartRpcCall.java:230)

                      ... 6 more









              • 4. Re: Analysis charts not working in OBIEE12c
                Andrew Fomin.



                I've faced this issue today. The symptoms were exactly the same.


                Please check your $ORACLE_HOME/user_projects/domains/bi/servers/obijh1/logs/jh.log log file. There was the following error in my case:

                [2015-11-19T13:48:13.725+03:00] [bi] [ERROR] [] [oracle.bi.nanserver.fwk.service] [tid: 22] [ecid: 2ad3672b-d3a2-4a5c-861f-25bcff2e08d5-000007dd,0:1:31:1] Error[[

                java.lang.NoClassDefFoundError: Could not initialize class sun.awt.X11GraphicsEnvironment

                        at java.lang.Class.forName0(Native Method)

                        at java.lang.Class.forName(Class.java:264)

                        at java.awt.GraphicsEnvironment.createGE(GraphicsEnvironment.java:103)

                        at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(GraphicsEnvironment.java:82)


                My server is working without a graphical environment, but DISPLAY variable was set to localhost:11.0.


                After I unset DISPLAY and restarted OBIEE, charts are working.

                • 5. Re: Analysis charts not working in OBIEE12c
                  Pierre Timmermans

                  Thank you very much, it solved the problem for me also