adcfgclone failing on fs2 as it is picking run fs config details

3129393

    Hello Experts,

     

     

    1- On fs1 - i ran  adpreclone.pl appsTier,  then copied EBSapps to fs2,  I made sure that there is no  fmw_home and inst in fs2

     

    2- Initiated adcfgclone.pl  appsTier on fs2 (with out sourcing the env)

     

    3- Please see below , s_config_home  is pointing to fs1  and target home are picked from fs1 instead of fs2,  all the targets are pointing to fs1

     

     

    Do you want to add a node (yes/no) [no] :

     

    Running:

    /u01/applebiz/fs2/EBSapps/comn/clone/bin/../jre/bin/java -Xmx600M -cp /u01/applebiz/fs2/EBSapps/comn/clone/jlib/java:/u01/applebiz/fs2/EBSapps/comn/clone/jlib/xmlparserv2.jar:/u01/applebiz/fs2/EBSapps/comn/clone/jlib/ojdbc6.jar:/u01/applebiz/fs2/EBSapps/comn/clone/jlib/obfuscatepassword.jar:/u01/applebiz/fs2/EBSapps/comn/clone/jlib/ojmisc.jar:/u01/applebiz/fs2/EBSapps/comn/clone/jlib/java:/u01/applebiz/fs2/EBSapps/comn/clone/jlib/emCfg.jar oracle.apps.ad.context.CloneContext -e /u01/applebiz/fs2/EBSapps/comn/clone/bin/../context/apps/CTXORIG.xml -validate -pairsfile /tmp/adpairsfile_32375.lst -stage /u01/applebiz/fs2/EBSapps/comn/clone  2> /tmp/adcfgclone_32375.err; echo $? > /tmp/adcfgclone_32375.res

     

    Log file located at /u01/applebiz/fs2/EBSapps/comn/clone/bin/CloneContext_1211104006.log

     

    Target System File Edition type [run] : patch

     

    Enter the full path of Run File System Context file : /u01/applebiz/fs1/inst/apps/DEV_appsserver/appl/admin/DEV_appsserver.xml

     

    Provide the values required for creation of the new APPL_TOP Context file.

     

    Target System Fusion Middleware Home set to /u01/applebiz/fs1/FMW_Home

     

    Target System Web Oracle Home set to /u01/applebiz/fs1/FMW_Home/webtier

     

    Target System Appl TOP set to /u01/applebiz/fs1/EBSapps/appl

     

    Target System COMMON TOP set to /u01/applebiz/fs1/EBSapps/comn

     

    RC-00217: Warning: Configuration home directory (s_config_home) evaluates to /u01/applebiz/fs1/inst/apps/DEV_appsserver. A directory with this name already exists and is not empty.

     

    Do you want to continue (y/n)   : n

     

     

    Please help

      • 1. Re: adcfgclone failing on fs2 as it is picking run fs config details
        Hussein Sawwan-Oracle

        What are you trying to do here? Adding a new node?

         

        Are you following the steps in (2047809.1)?

         

        Is this a shared or non-shared file system?

         

        Did you already configure the RUN edition file system on the target node?

         

        What's your TXK/AD delta patchset level?

         

        Thanks,

        Hussein

        1 位用户发现它有用
        • 2. Re: adcfgclone failing on fs2 as it is picking run fs config details
          3129393

          Hello,

           

          RUN FS is already setup and working fine . I am trying to configure fs2, This is single DB & single MT.

           

          we have other 3 test instance where i was able to clone and configure fs2 successfully,  Only this instance, i am having issue while configuring fs2

           

          SQL> select  bug_number ,last_update_date  from  apps.ad_bugs where bug_number in  ('18283295','18288881','19197270','19330775','20745242','20784380');

           

          we are on delta 6

           

          BUG_NUMBER                     LAST_UPDATE_DAT

          ------------------------------ ---------------

          18283295                       26-NOV-15

          18288881                       26-NOV-15

          19197270                       26-NOV-15

          19330775                       26-NOV-15

           

          Problem - When running adcfgclone.pl on fs2, the targets are shown as fs1, config details are picked from fs1.

           

          Please let me know if any further information is needed

           

          Thank you

          • 3. Re: adcfgclone failing on fs2 as it is picking run fs config details
            3129393

            Hello,

             

            I tried this again,

             

            1- Ran adpreclone.pl on Run FS

            2- Copied clone directory from   fs1 to fs2   comn

            3- Ran adcfgclone.pl on Patch FS (fs2)

            4- Failing,  this is pointing to fs1, ideally it should say fs2

             

             

             

            Running:

            /u01/applebiz/fs2/EBSapps/comn/clone/bin/../jre/bin/java -Xmx600M -cp /u01/applebiz/fs2/EBSapps/comn/clone/jlib/java:/u01/applebiz/fs2/EBSapps/comn/clone/jlib/xmlparserv2.jar:/u01/applebiz/fs2/EBSapps/comn/clone/jlib/ojdbc6.jar:/u01/applebiz/fs2/EBSapps/comn/clone/jlib/obfuscatepassword.jar:/u01/applebiz/fs2/EBSapps/comn/clone/jlib/ojmisc.jar:/u01/applebiz/fs2/EBSapps/comn/clone/jlib/java:/u01/applebiz/fs2/EBSapps/comn/clone/jlib/emCfg.jar oracle.apps.ad.context.CloneContext -e /u01/applebiz/fs2/EBSapps/comn/clone/bin/../context/apps/CTXORIG.xml -validate -pairsfile /tmp/adpairsfile_29915.lst -stage /u01/applebiz/fs2/EBSapps/comn/clone  2> /tmp/adcfgclone_29915.err; echo $? > /tmp/adcfgclone_29915.res

             

            Log file located at /u01/applebiz/fs2/EBSapps/comn/clone/bin/CloneContext_1211141101.log

             

            Target System File Edition type [run] : patch

             

            Enter the full path of Run File System Context file : /u01/applebiz/fs1/inst/apps/DEV_server/appl/admin/DEV_appsserver.xml

             

            Provide the values required for creation of the new APPL_TOP Context file.

             

            Target System Fusion Middleware Home set to /u01/applebiz/fs1/FMW_Home

             

            Target System Web Oracle Home set to /u01/applebiz/fs1/FMW_Home/webtier

             

            Target System Appl TOP set to /u01/applebiz/fs1/EBSapps/appl

             

            Target System COMMON TOP set to /u01/applebiz/fs1/EBSapps/comn

             

            RC-00217: Warning: Configuration home directory (s_config_home) evaluates to /u01/applebiz/fs1/inst/apps/DEV_appsserver. A directory with this name already exists and is not empty.

             

             

            Can some one please help ,  not sure why this is picking fs1 instead of fs2

             

            Thank you

            • 4. Re: adcfgclone failing on fs2 as it is picking run fs config details
              Hussein Sawwan-Oracle

              Have you had any previous failed attempts on the PATCH file system? If yes, did you complete the steps under "Appendix A: Steps to be performed before restarting a Failed Rapid Clone" before running postclone again?

               

              Thanks,

              Hussein

              • 5. Re: adcfgclone failing on fs2 as it is picking run fs config details
                3129393

                Hello Hussein,

                 

                The failed attempts are as explained in my previous update in the discussion. Appendix 1 asks to perform clone on both run and patch fs. My Run FS is setup and working fine. User are able to login and doing there testing already since couple of days.

                 

                I am having issues while configuring Patch fs. adcfgclone.pl is pointing to fs1 on patch fs , let me know if any further details are needed.

                 

                Thank you

                • 6. Re: adcfgclone failing on fs2 as it is picking run fs config details
                  Hussein Sawwan-Oracle

                  My reply was to clean anything related to PATCH FS as explained in the Appendix. If this was already performed and you still hit the same issue then please log a SR.

                   

                  Thanks,

                  Hussein

                  • 7. Re: adcfgclone failing on fs2 as it is picking run fs config details
                    3129393

                    Ok, Thanks. I've logged SR. will let you know once i have a solution in place

                    • 8. Re: adcfgclone failing on fs2 as it is picking run fs config details
                      3129393

                      Root Cause & Solution -

                      =================

                       

                      Following two variables on RUN context file were pointing to fs1 instead of fs2, I've changed them to point to fs2 (patchFS) and ran autoconfig on runFS, then ran adcfgclone.pl on PatchFS, it went sucessful

                      <OTHER_BASE oa_var="s_other_base">/u01/applebiz/fs2</>

                       

                        <clonestage oa_var="s_clonestage">/u01/applebiz/fs2/EBSapps/comn/clone</clonestage>

                       

                      Happy Learning !!

                       

                      Thanks

                      Tanveer Mohammed