4 Replies Latest reply on Feb 11, 2016 3:57 PM by BrianPa

    Monitoring Oracle 11gR2 XE with OEM 13c


      Has anybody out there had any luck monitoring an Oracle 11g XE (Linux x86-64, database with Oracle Enterprise Manager 13c?


      I have EM12cR4 ( and EM13c both running on separate servers.  Each managed host has both a 12c agent and a 13c agent running.  On one of my servers (SLES 11 SP3 64 bit) I have an Oracle 11g XE installation up and running.  My EM12c installation can monitor this Oracle XE database with no issues.  My EM13c installation encounters metric evaluation errors immediately upon adding the Oracle XE target database.  Both agents run as the same user account ('oraagent'). Both agents are using the same database DBSNMP user account. The 'Test Connection' button on the EM13c Target Setup -> Monitoring Configuration screen returns a successful connection. Many of the EM13c screens seem to function correctly for this database target - I can use every screen I have tested under the Administration, Schema, Security, Availability, and Performance menus, but EM13c is unable to get past these metric evaluation errors and identify the target status.


      The metric errors that EM13c encounters appear in the incident manager screen as:


      "Metric evaluation error start - Target {oracle_database.SID.domain.com} is broken: Dynamic Category property error,Get dynamic property error,No such metadata - No valid queryDescriptor or executionDescriptor found for target [oracle_database.SID.domain.com$30]"


      and for the database system target:


      "Metric evaluation error start - Received an exception when evaluating sev_eval_proc for:Target name = SID.domain.com_sys, metric_name = Response, metric_column = Status; Error msg = Target encountered metric erros; at least one member in in metric error"

      I can live without seeing a target status on this database, but right now the fact that I cannot schedule backup jobs against this XE database is the only thing preventing me from moving my production monitoring fully onto EM13c and shutting down my EM12c system.  Jobs run against this target get suspended immediately with "Suspended: Target is not Ready".


      I have turned on debugging at the agent level and traced log files during the course of attempting to add the target.  After doing so, there are three dynamic properties that the agent cannot compute for this target:


      2016-01-15 12:10:05,905 [1806:4CE3192] DEBUG - Computing of dynamic property: [ComputeVC] is done (1 msec, error=true)

      2016-01-15 12:10:06,452 [1806:F917F5F8] DEBUG - Computing of dynamic property: [GetDumpDestination] is done (0 msec, error=true)

      2016-01-15 12:10:06,508 [1813:6EEEAC87] DEBUG - Computing of dynamic property: [DeduceAlertLogFile] is done (1 msec, error=true)


      Other dynamic properties are computed correctly:


      2016-01-15 12:35:38,038 INFO - Finished dynamic properties computation (total time 817 ms). Number of DP computed: 19. Number of DP with error: 3. Number of dynamic properties that were added: 132.


      The ComputeVC dynamic property (which appears to determine the database's version category) appears to be unable to parse the Oracle 11g XE version string:


      2016-01-15 12:11:18,779 [1830:CD3A325D] DEBUG - Error was added to oracle_database.SID.domain.com$23(0|MONITORED|false|true|<UF>): Invalid Input                                                                             

      2016-01-15 12:11:18,779 [1831:3657AE55] DEBUG - abandoning long op "CDProps:oracle_database.SID.domain.com:ComputeVC:GENERIC_TASK:Fri Jan 15 12:11:18 EST 2016"

      2016-01-15 12:11:18,780 [1830:CD3A325D] DEBUG - Error during dynamic property ComputeVC calculation: critical=true, missingCatProps=[VersionCategory], missingProps=[VersionCategory]

      oracle.sysman.emSDK.agent.fetchlet.exception.FetchletException: Invalid Input

          at oracle.sysman.gcagent.addon.fetchlet.versionRange.VersionRange.getMetric(VersionRange.java:78)
          at oracle.sysman.gcagent.target.interaction.execution.FetchletFactory.getMetric(FetchletFactory.java:431)


      The other two failing dynamic properties appear to be failing as a side effect of losing the database connection after the ComputeVC property calculation fails.


      From other information in the logs it seems like EM13c might be attempting to access the BUNDLE_SERIES column in dba_registry_history (which does not exist in XE) and perhaps failing due to that. 


      Does anyone have 11gR2 XE added as a fully functional target in their EM13c environment?




        • 1. Re: Monitoring Oracle 11gR2 XE with OEM 13c

          Sorry all, please disregard.  I have resolved this on my own.  The missing BUNDLE_SERIES column in DBA_REGISTRY_HISTORY on XE was the source of my inability to monitor XE from EM13c.



          As the monitoring user (DBSNMP, in my case) I created a new, empty DBA_REGISTRY_HISTORY table including a BUNDLE_SERIES column in the monitoring user's schema.




          I then forced recalculation of dynamic properties for the target via the EM13c agent:


          $ emctl reload agent dynamicproperties SID.domain.com:oracle_database

          Oracle Enterprise Manager Cloud Control 13c Release 1

          Copyright (c) 1996, 2015 Oracle Corporation.  All rights reserved.


          EMD recompute dynprops completed successfully



          Once that command completed successfully my Oracle XE database target appears with the correct 'up' status and I can submit jobs to run against it.  I cannot recommend that anybody else follows the steps I did, instead I have to suggest you wait for a fix from the OEM team, but I had an urgent need to move away from my EM12c installation due to failing hardware.

          • 2. Re: Monitoring Oracle 11gR2 XE with OEM 13c



            I had the same problem on Linux since one month. I tried your solution and it works fine :=) I have a bug opened at Oracle, hope they will publish a fix.


            The thing I do not understand is why this view has no bundle_series column  in a database , and this column exist in another database .....




            • 3. Re: Monitoring Oracle 11gR2 XE with OEM 13c
              Jason Lentz

              I hit this same error and issue. I traced my problem to some difficulty we encountered upgrading from to last year. Some post-upgrade scripts were not run as part of the migration process. I ran the following script and it refreshed this view with the correct columns.




              SQL> desc dba_registry_history

              Name                                      Null?    Type

              ----------------------------------------- -------- ----------------------------

              ACTION_TIME                                        TIMESTAMP(6)

              ACTION                                             VARCHAR2(30)

              NAMESPACE                                          VARCHAR2(30)

              VERSION                                            VARCHAR2(30)

              ID                                                 NUMBER

              BUNDLE_SERIES                                      VARCHAR2(30)

              COMMENTS                                           VARCHAR2(255)


              I also ran these two post-upgrade scripts just for posterity, though they did not impact this issue.




              1 person found this helpful
              • 4. Re: Monitoring Oracle 11gR2 XE with OEM 13c

                Hi 2604825,


                Since you mentioned an upgrade, it sounds to me like you're saying you saw this behavior on a regular (SE, EE) Oracle database and not on an XE edition?  Interesting!  That's a great find, thanks for posting.