0 Replies Latest reply on Apr 25, 2016 7:16 AM by user5310879

    Agent Unreachable is cleared. The current status of the target is METRIC ERROR

    user5310879

      Hi Guys,

      i have a terrible problem with oem cloud control 12c, i'm newbie in oracle. so please guide me to make this problem solved.

       

      let me tell you about my problem

           OMS home -> based on oracle linux 6.5

           Agent1     -> under OMS home

           Agent2     -> solaris 10 upd 11

       

      Agent1 have no problem with oms, it can be monitored in oem cloud control 12c, the problem is agent2.

      i have been this problem and try to solve it for 2 weeks.

       

      i installed the agent2 using oem cloud control 12c, i did 'self update' and applied 'solaris x64 for sparc', and i 'add target manually' and entered the agent2's IP, user n password in there.

      i run root.sh manually because there was no sudo file in solaris.

       

      yesterday i've got problem with 'agent unreachable', oms version not checked yet, i have try with any tricks, and only one below trick can solve it.

           https://docs.oracle.com/cd/E24628_01/install.121/e22624/install_agent.htm#EMBSC182

      1. Navigate to the following location in the OMS home:

        $<OMS_HOME>/oui/prov/resources/scripts

        For example,

        /home/software/em/middleware/oms/oui/prov/resources/script

      2. If the OMS host runs on any Unix based operating system, run the sshUserSetup.sh script on the OMS host as the OMS user, and pass the Management Agent install user name and the fully qualified name of the target hosts:

        sshUserSetup.sh -setup -user <agent_install_user_name> -hosts "<target_hosts>"

        For example, sshUserSetup.sh -setup -user oracle -hosts "abc1.example.com abc2.example.com abc3.example.com". Ensure that you use a space to separate the target host names.

        The following SSH keys are created:

      and finally, agent status looks great after i did this above tricks before i install the agent for solaris.

       

      putty@agent2> ./emctl status agent

      Oracle Enterprise Manager Cloud Control 12c Release 5

      Copyright (c) 1996, 2015 Oracle Corporation.  All rights reserved.

      ---------------------------------------------------------------

      Agent Version          : 12.1.0.5.0

      OMS Version            : 12.1.0.5.0

      Protocol Version       : 12.1.0.1.0

      Agent Home             : /vd2/oratest1/epmdb/11.2.0.4/xxcoba/agent_inst

      Agent Log Directory    : /vd2/oratest1/epmdb/11.2.0.4/xxcoba/agent_inst/sysman/log

      Agent Binaries         : /vd2/oratest1/epmdb/11.2.0.4/xxcoba/core/12.1.0.5.0

      Agent Process ID       : 13693

      Parent Process ID      : 13680

      Agent URL              : https://panoramix2.enseval.com:3872/emd/main/

      Local Agent URL in NAT : https://panoramix2.enseval.com:3872/emd/main/

      Repository URL         : https://yoga:4903/empbs/upload

      Started at             : 2016-04-25 10:01:49

      Started by user        : oratest1

      Operating System       : SunOS version 5.10 (sparcv9)

      Last Reload            : (none)

      Last successful upload                       : (none)

      Last attempted upload                        : (none)

      Total Megabytes of XML files uploaded so far : 0

      Number of XML files pending upload           : 0

      Size of XML files pending upload(MB)         : 0

      Available disk space on upload filesystem    : 99.22%

      Collection Status                            : Collections enabled

      Heartbeat Status                             : Ok

      Last attempted heartbeat to OMS              : 2016-04-25 10:20:58

      Last successful heartbeat to OMS             : 2016-04-25 10:20:58

      Next scheduled heartbeat to OMS              : 2016-04-25 10:21:58

       

      ---------------------------------------------------------------

      Agent is Running and Ready

       

      putty@agent2> ./emctl upload agent

      Oracle Enterprise Manager Cloud Control 12c Release 5

      Copyright (c) 1996, 2015 Oracle Corporation.  All rights reserved.

      ---------------------------------------------------------------

      EMD upload completed successfully

       

       

      but unfortunatelly, this agent2 installation isn't successfull again with other problem.

       

      Status : Agent Unreachable is cleared. The current status of the target is METRIC ERROR

       

      To troubleshoot, refer to My Oracle Support article Enterprise Manager 12c: How to run the "Targets Status Diagnostics Report" to Troubleshoot Target Status Availability Issues (up, down, metric collection error, pending, unreachable) for all Targets (Doc ID 1546575.1).

       

       

      Broken Reason : unable to connect to http server at https://<agent2-IP>:3872/emd/main/. [peer not authenticated]

       

      what is wrong with this installation? is it because there is bug in oem 12c or what? im getting frustating till now, i have search many tricks for this problem, but i've got nothing solved it.

       

      please kindly help me to get out of this problem... my purpose is just to manage my solaris agent database, which managed with oem 11g now,  and now i wanna try to managed it with 12c.

      bcs i have to move all databases which run in solaris, into oem cloud control 12c.

       

      Thanks before.

      Best Regards,

       

      Yoga