This discussion is archived
6 Replies Latest reply: Apr 17, 2007 6:42 AM by 551112 RSS

Event-Data

505303 Newbie
Currently Being Moderated
Hi,
I have the following Problem: I have an Application connected on the Remote-Driver.
I want to collect events adressed to this driver and analyze the Event-Data.
When is send an Event via edge/tools/sendEvent.html or edg_utl.sendToEdge the event is submitted and successfully recieved but the data-filed just contains the data of the Id-Field.

My input into the data-fieled looks like this:
<Order><PRODUCT_NUMBER>2134a</PRODUCT_NUMBER>     
     <BATCH_NUMBER>12a</BATCH_NUMBER>
     <PACKAGE_TYPE>22cd</PACKAGE_TYPE>
     <TOTAL_AMOUNT>200</TOTAL_AMOUNT>
     <NUMBER_OF_PACKAGES>5</NUMBER_OF_PACKAGES>
     <PIECES_PER_CASE>4</PIECES_PER_CASE>
     <CASES_PER_PALLETTE>5</CASES_PER_PALLETTE>
     <MAX_FILL_WEIGHT>100</MAX_FILL_WEIGHT>
     <MIN_FILL_WEIGHT>50</MIN_FILL_WEIGHT>
     <MAX_TOTAL_WEIGHT>100</MAX_TOTAL_WEIGHT>
     <MIN_TOTAL_WEIGHT>50</MIN_TOTAL_WEIGHT>
</Order>
The Type is 550, the subtype is 0
To read the data i used the oracle.edge.tools.io.EventSocket-Class


Any Idea what is wrong?

Message was edited by:
user502300

Message was edited by:
user502300
  • 1. Re: Event-Data
    207512 Newbie
    Currently Being Moderated
    Sounds like you are doing most of it correctly. Two hints thou:
    - Can you trap the socket xml message to see if it is missing there? If it is, the sender is the problem
    - When you put the xml in the data, did you escape the xml tags first ( like replace all < with &lt;, etc)

    If you couldn't get any further, I can post a remotedriver test client, that will just dump out the messages.

    Thx -- Sam
  • 2. Re: Event-Data
    505303 Newbie
    Currently Being Moderated
    Hi Sam,
    the supplied XML-Data looks like this:

    <Event>
    <Routing>
    <siteName>BHG</siteName>
    <correlationId></correlationId>
    <from>sendEvent-Page</from>
    <to>ProductionLineDevice</to>
    </Routing>
    <Metadata>
    <type>550</type>
    <subType>0</subType>
    </Metadata>
    <Payload>
    <createTime>1151275194203</createTime>
    <item id="MY_ID">MY_ID</item>
    </Payload>
    </Event>

    So it seems like the Data-Segment is missing. I didn't use this time no xml in the Data-Field so <, isn't the problem.
    The Edg-Utl. Command looks like this:
    call Edg_utl.sendtoedge (101, 0,'myItemID' ,'BHG', 'ProductionLineDevice', 'MY_TESTDATA', sysdate,'src','cor');
    So maybe we should try the remote-Driver test-client

    Regards Jan
  • 3. Re: Event-Data
    523086 Newbie
    Currently Being Moderated
    I think this was a bug in the Event class that was in one of the 10.1.3.0 patches. Basically, the Event's toXML method was generating id instead of data for the payload.
  • 4. Re: Event-Data
    505303 Newbie
    Currently Being Moderated
    Well it's not just the toXML Method, the main Problem is that .getData() delivers the ID and not the required Data....
  • 5. Re: Event-Data
    505303 Newbie
    Currently Being Moderated
    Thanks a lot the patch solved the problem :-)
  • 6. Remote Driver
    551112 Newbie
    Currently Being Moderated
    Hi ,

    I have configured the remote driver to listen a port where the event data is published.(<event> </event>)

    I need to read this data from the port and forward to a oracle table after processing. Can remote driver listen to the port and display in the edge server "monitor event" ? From there I will also set up a rule to forward to a particular location.

    Is Remote Driver the right one to do this job or I have understood anything completely wrong?? Kindly help.

    After setting the remote driver, there is no error message/events shown in monitor events. Should I customise the code to do this job?? If customisation is needed, can you direct me to any documents to help get started.

    Thanks
    Lakshmi