Sending mail from Linux to users E-mails via Oracle EBS R12.1.3

Noname123

    My system:

    Linux Redhat 5

    Oracle database 11g.

    oracle EBS R12.1.3

     

    My requirement

    Sending attachment files (pdf files) stored in my linux server along with a two paragraphs  content  to my E-mail.  One paragraph in  Arabic and another in  English.

     

     

     

    What I have did:

    In  Alert manager responsibility ---> Alert ---> Define

    Action type ---> operating system script

     

    Then I have defined the action details to perform the job.

     

     

    Here is the command:

     

     

    (echo  "

    In this paragraph I have written Arabic paragraph.

     

    In this paragraph I have written English paragraph.

    along with uuencoding the attachement files. as below

    uuencode /var/tmp/8.pdf Regulation_Rules_Sanctions.pdf; ) | mailx -s "Welcome mail" <myemail>@<domain>  -- -f erpadmin@<domain>

     

     

    What E-mail content I am getting as a result:

    1- Attachments are sent successfully.

    2- The English paragraph is sent and displayed to me clearly.

    3- The Arabic paragraph is not displayed correctly.  And it looks like the following:

     

    ÇáÓáÇã Úáíßã æÑÍãÉ Çááå æÈÑßÇÊå

     

     

     

    Then later I tried to add content-type and charset parameter as option to mailx command but it  is not working.

    And it returns invalid option

     

    Error message:

    mailx: invalid option -- a

    Usage: mail [-iInv] [-s subject] [-c cc-addr] [-b bcc-addr] to-addr ...

      [-- sendmail-options ...]

      mail [-iInNv] -f [name]

      mail [-iInNv] [-u user]

    uuencode: Write error

    uuencode: Write error

    uuencode: Write error

    uuencode: Write error

    uuencode: Write error

    uuencode: Write error

    uuencode: Write error

    uuencode: Write error

    /bin/sh: line 12: -s: command not found

    APP-ALR-04021: Oracle Alert was unable to perform the command "(echo "¿¿¿¿¿¿ ¿¿¿¿¿ ¿¿¿¿¿ ¿¿¿¿ ¿¿¿¿¿¿¿

     

    So, I reverted the changes.

     

     

    Any idea how to display the Arabic content properly? Thanks in advanced.