3 Replies Latest reply on Jun 28, 2017 7:54 PM by dml247-OC

    Grid 12.x init.ohasd not starting on kernel 3.10.0-514.21.2

    Bernd Patolla

      Hi all,


      I'm just engineering our new Linux (RHEL 7.3) platform. We want to use ASM as the storage interface.

      In the last days I tried to get the Oracle Restart (service oracle-ohasd) to start on the "Stack Guard" save kernel 3.10.0-514.21.2.el7.

      What have I done?

      Installed Grid Infrastructure 12.1 (and later 12.2) on my test box, configured it and got ASM running, having a DG mounted. So everything is working.

      I stopped ASM. Then I stopped and disabled has (crsctl disable has; crsctl stop has).

      Then I run a yum update and installed the updated kernel 3.10.0-514.21.2.el7

      Rebooted the box.

      After reboot I enabled and tried to start has.

      I didn't get it up and running.

      I also looked in every log file I found (including dmesg, /var/log/messages, journalctl, ...) but I didn't see any failure message.


      Can you tell me how to trouble shoot this problem (maybe some logfiles I didn't see, how to set debug mode for ohasd.bin, oraagent, evmd.bin, ...)?


      If I restart the system with the old kernel, everything starts and is working.