Auto reinstate fails, after the failover Via observer

3390386

    We have 3 database on Primary server and 3 standby database configured accordingly. It is physical standby dataguard setup.

    Windows: Version 12.1.0.2.0 - 64bit Production.

     

    DGMGRL configuration created separately for each database and performed the switchover testing and everything working fine.

    Observer configured and did the failover test. The standby become primary and it is up and running. 

     

    Now the problem ,

    The former primary is not coming up and auto reinstate failed. Manually started and mount the database, then the observer trying to do the auto reinstate, but it fails. Manual auto reinstate also failing. Autoreinstate parameter set as TRUE.

     

    DGMGRL> show configuration

     

    Configuration - dgconfig1

     

      Protection Mode: MaxPerformance

      Members:

      sawprod_stdby - Primary database

      Warning: ORA-16829: fast-start failover configuration is lagging

     

      sawprod - (*) Physical standby database (disabled)

      ORA-16661: the standby database needs to be reinstated

     

    Fast-Start Failover: ENABLED

     

    Configuration Status:

    WARNING (status updated 2 seconds ago)

     

    DGMGRL> reinstate database sawprod << ==================================

    Reinstating database "sawprod", please wait...

    Error: ORA-16653: failed to reinstate database

     

    Failed.

    Reinstatement of database "sawprod" failed

    DGMGRL>