2 Replies Latest reply: Aug 15, 2007 7:54 AM by Gmfeinberg-Oracle RSS

    problem building BDBXML in Solaris 10

    534638
      Hi,
      I'm trying to build BDBXML in Solaris 10 to produce 64 bit libraries (Sun Fire T1000 server).
      I use the build script as follows :

      ---------------------------------------------------------------
      ./buildall.sh -p solaris -b 64 -c cc -x CC -m /usr/sfw/bin/gmake with-dbxml-prefix=/usr/local/BerkeleyDBXML.2.2 with-berkeleydb-prefix=/usr/local/BerkeleyDB.4.3 with-pathan-prefix=/usr/local/pathan with-xerces-prefix=/usr/local/xerces with-xquery-prefix=/usr/local/xquery.1.2  enable-java
      ---------------------------------------------------------------

      The build terminates with an error :

      "/downloads/dbxml-2.2.13/pathan/include/pathan/internal/StringPool.hpp", line 75:Error: The function "memcpy" must have a prototype.
      1 Error(s) detected.

      Another problem I noticed is, though I specified -b 64 option in the build script, it produces 32 bit
      BerkleyDB library. It produces xerces library as 64 bit.

      Please help me.

      -Anoop
        • 1. Re: problem building BDBXML in Solaris 10
          593088
          Pertaining to my comment and the response from George Feinberg here:

          http://cafe.elharo.com/xml/the-state-of-native-xml-databases/

          After we received no response to this thread, I tried addressing the issue through our account rep, and we provided all the information requested (along with the fixes we could make):

          "I'm working with our product engineers on this, and they have asked to find out the compiler being used, and flags being passed to the buildall.sh script, along with full output of the build (which will include the error messages)."

          After that, nothing, despite repeated followup on my part including an offer of an admin login on our server, and repeated promises by Oracle to have a Sleepycat developer work with us directly on this issue. Responses from the (unpaid) eXist developers on their mailing list take hours, not months, by comparison. So you'll please excuse the opinions I formed as a result of this experience, my comment at cafe.elharo.com was not made lightly. We tried 2.3.10 and had the same problems btw.
          • 2. Re: problem building BDBXML in Solaris 10
            Gmfeinberg-Oracle
            Eric,

            Given the date of the initial post I have found the email thread that resulted from your correspondence with an account rep. It seems to have gone silent (i.e. no more emails to me) about 10/2/2006.

            I am sorry that communication was so difficult. I never received your offer of using the machine, which would I have gladly taken since we do not have such a configuration available in-house. If it is still available after all this time, I'd be happy to work on fixing the problems. It doesn't matter if you are using another product -- I want to fix any build issues we've got. You can contact me directly via email at george dot feinberg @ the obvious domain.

            Regards,
            George