1 2 3 Previous Next 35 Replies Latest reply on Feb 8, 2018 9:54 AM by Petede-Oracle

    Solaris 11.4 Beta

    Geri H-Oracle

      Welcome to the Solaris Beta Forum!


      Thank you for trying out our latest beta release of Oracle Solaris 11.4.


      Do you have questions about how to use a new feature? Just ask here! If you have a support contract, you can log a service request at support.oracle.com to report a problem or bug. If you don't have a support contract, report the problem here.  We have a team of engineers and product managers watching this forum to make sure you can get the most out of Oracle Solaris 11.4.


      Don't have Solaris 11.4  Beta yet?  Download here:

      Oracle Solaris 11.4 Beta

        • 1. Re: Solaris 11.4 Beta

          I have just made a clean install of the 11.4 public beta from the .usb installer that I downloaded today.


          I tried then to compile some tools but discovered that I have no compiler.

          pkg install gcc-45 says "no update necessary" but gcc is missing

          pkg install gcc-5 gives an


          pkg install: No matching version of developer/gcc-5 can be installed:

            Reject:  pkg://solaris/developer/gcc-5@5.4.0-

          A pkg publisher reports (default from setup)

          PUBLISHER                   TYPE     STATUS P LOCATION

          solaris                            origin      online F      http://pkg.oracle.com/solaris/release/


          I got a hint that I should use the beta publisher, but I cannot access
          (I registered and downloaded key and cert  and accepted the license)



          So it seems the default publisher is wrong
          and the beta publisher is not free (public beta???)

          • 2. Re: Solaris 11.4 Beta
            Darren Moffat-Oracle

            This is not a bug in the product.


            You need to go to https://pkg-register.oracle.com/ and get the private key and certificate to configure the /beta repository.

            The page where you download your personal key/cert also shows you exactly what to run to configure the /beta repository.

            The packages in the /release repository are not for the beta release but for 11.3 and earlier.

            • 3. Re: Solaris 11.4 Beta


              shows access granted to 11.4 beta


              I downloaded key and cert and tried (files in /root)
              pkg set-publisher -c /root/pkg.oracle.com.certificate.pem -k /root/pkg.oracle.com.key.pem -g https://pkg.oracle.com/solaris/beta solaris


              but got

              https protocol error: Unknown error code: 401 reason: Unauthorized

              URL: 'https://pkg.oracle.com/solaris/beta'


              Why is the publisher for a public beta locked??

              • 4. Re: Solaris 11.4 Beta
                Marcel Hofstetter JomaSoft

                It make take a few minutes, till the registration is active.

                Retry ...


                Best regards,

                Marcel Hofstetter

                JomaSoft GmbH

                • 5. Re: Solaris 11.4 Beta

                  Hi there,


                  When you went to the pkg-register app did you accept the license for the Oracle Solaris 11.4 Beta prior to downloading the key/cert pair ?


                  If you go to the pkg-register application and login into it what do you see under the Repositories tab ? For the 11.4 Beta do you see a red button showing 'show details' or 'Request access' ?


                  This is a free beta just that you have to review and accept the license.




                  • 6. Re: Solaris 11.4 Beta

                    The beta repository works now.
                    You simply have to wait some time after accepting the license (thanks Marcel)


                    I was now able to install packages like a compiler


                    - Why do you deliver 11.4 public beta with a non workable repository?


                    Only with your help (you and other Oracle staff) I was able to discover the beta repository and setup the beta repository.  An average user that downloads the software simply comes to a conclusion: nonworkable crap


                    Is it intended to offer such a worse user experience with a dysfunctional software
                    to hope that everyone skip Solaris as useless and eol and move to your Linux?


                    Why do you not simply use a beta repository for the beta and add the stable repository later to the final.

                    • 7. Re: Solaris 11.4 Beta
                      Glenn F

                      Hi Geri,


                      Congratulations on launching Solaris 11.4 beta!


                      I downloaded and installed the Vbox template and it worked smoothly by following the link on this page:

                      Oracle Solaris 11.4 Beta


                      Then I was also able to register with the Solaris 11.4 beta repository by following these instructions:

                      How to Access Oracle Solaris 11.4 Beta Packages from pkg.oracle.com


                      This is fairly straight-forward for an experienced Solaris user like me, but it could be made more obvious by providing a link to the registration instructions on the (above) downloads page.


                      A minor nit is that the certs were downloaded to the Downloads directory, so I had to move them to the Desktop directory. Another nit is that the instructions use sudo instead of pfexec. But that's just a matter of familiarity.



                      • 8. Re: Solaris 11.4 Beta

                        Maybe one of the more experienced Solaris people can give me a hint about this issue in 11.4


                        I installed gcc-5 as I need the Perl Expect modul, especially the IO:Tty (Tty.so).
                        I usually compile Expect via


                        perl -MCPAN -e shell

                        install Expect


                        I got the following error:

                        Has anyone an idea as this problem is new in 11.4?



                        Running Mkbootstrap for IO::Tty ()

                        chmod 644 "Tty.bs"

                        "/usr/perl5/5.22/bin/perl" "/usr/perl5/5.22/lib/ExtUtils/xsubpp"  -typemap "/usr/perl5/5.22/lib/ExtUtils/typemap"  Tty.xs > Tty.xsc && mv Tty.xsc Tty.c


                        cc: error: unrecognized command line option '-KPIC'

                        *** Error code 1

                        make: Fatal error: Command failed for target `Tty.o'

                        Current working directory /root/.cpan/build/IO-Tty-1.12-4


                          /usr/bin/make -- NOT OK

                        Running make for module 'IO::Tty'


                          Has already been unwrapped into directory /root/.cpan/build/IO-Tty-1.12-4


                          Has already been prepared


                          Could not make: Unknown error




                          Has already been unwrapped into directory /root/.cpan/build/Expect-1.35-4


                          Has already been prepared

                        Running make for J/JA/JACOBY/Expect-1.35.tar.gz

                        Warning: Prerequisite 'IO::Pty => 1.11' for 'JACOBY/Expect-1.35.tar.gz' failed when processing 'TODDR/IO-Tty-1.12.tar.gz' with 'make => NO'. Continuing, but chances to succeed are limited.

                        Warning: Prerequisite 'IO::Tty => 1.11' for 'JACOBY/Expect-1.35.tar.gz' failed when processing 'TODDR/IO-Tty-1.12.tar.gz' with 'make => NO'. Continuing, but chances to succeed are limited.

                        cp lib/Expect.pm blib/lib/Expect.pm

                        Manifying 1 pod document


                          /usr/bin/make -- OK

                        Failed during this command:

                        TODDR/IO-Tty-1.12.tar.gz                     : make NO

                        • 9. Re: Solaris 11.4 Beta



                          Does Solaris 11.4 support docker ?



                          Eldho Varghese

                          • 10. Re: Solaris 11.4 Beta
                            Darren Moffat-Oracle

                            For the majority of enterprise deployments of Solaris (which is the target market) the repository is downloaded or copied (using pkgrecv) to a host inside the corporate environment.  The individual Solaris instances then point to that internal copy of the repository rather than one on https://pkg.oracle.com/

                            You can download the repository images files from the same place on OTN as you downloaded the install or VM image and set those up on the host or on another system.

                            Or you can use the build in SMF IPS mirror service svc:/application/pkg/mirror

                            For more information see this section in the Solaris 11.4 Beta Documentation:  https://docs.oracle.com/cd/E37838_01/html/E60982/repo_intro.html for specific details on the pkg mirror service see https://docs.oracle.com/cd/E37838_01/html/E60982/pkgmirror.html


                            Even if we had the beta install images reference https://pkg.oracle.com/solaris/beta then you would still need to register for access and add the access keys, just like is required for the mirror service.

                            Note that this is exactly the same as the process used for access to the /support repository.

                            • 11. Re: Solaris 11.4 Beta
                              Darren Moffat-Oracle

                              From the perlsolaris man page:


                                 If you wish to use gcc to build add-on modules for use with the perl
                                 shipped with Solaris, you should use the Solaris::PerlGcc module which
                                 is available from CPAN.  The perl shipped with Solaris is configured
                                 and built with the Sun compilers, and the compiler configuration
                                 information stored in Config.pm is therefore only relevant to the Sun
                                 compilers.  The Solaris:PerlGcc module contains a replacement Config.pm
                                 that is correct for gcc - see the module for details.
                              • 12. Re: Solaris 11.4 Beta
                                Darren Moffat-Oracle

                                There is no delivered support for Docker in Oracle Solaris 11.4 Beta.

                                There is an implementation of the OCI (Open Container Initiative) runtime, that has been tested with older versions of Docker, but it is undocumented at this time, and may not be documented until a future (post 11.4) release.



                                Darren J Moffat: Senior Software Architect - Oracle Solaris Engineering

                                • 13. Re: Solaris 11.4 Beta

                                  Thank you but I got



                                  cd /root/Solaris-PerlGcc-1.3/

                                  root@solaris114:~/Solaris-PerlGcc-1.3# perl Makefile.PL

                                  Invalid Solaris version 5.11, this module is for Solaris 8, 9 & 10 only


                                  • 14. Re: Solaris 11.4 Beta
                                    Sandor F



                                    I just installed 11.4 beta repo, but the verification failed wiht some dependency errors:

                                    ./install-repo.ksh -d /repo/sol-11_4 -v

                                    Using sol-11_4-beta-repo download.

                                    Uncompressing sol-11_4-beta-repo_1of5.zip...done.

                                    Uncompressing sol-11_4-beta-repo_2of5.zip...done.

                                    Uncompressing sol-11_4-beta-repo_3of5.zip...done.

                                    Uncompressing sol-11_4-beta-repo_4of5.zip...done.

                                    Uncompressing sol-11_4-beta-repo_5of5.zip...done.

                                    Repository can be found in /repo/sol-11_4.

                                    Initiating repository verification.

                                    pkg://solaris/support/constraint/solaris-              2250/6437 |

                                               ERROR: Missing dependency.

                                             Package: pkg://solaris/support/constraint/solaris-,5.11:20170710T143106Z

                                          Dependency: entire@5.12-

                                    Dependency type: incorporate



                                    pkg://solaris/support/constraint/solaris-              2252/6437 |

                                               ERROR: Missing dependency.

                                             Package: pkg://solaris/support/constraint/solaris-,5.11:20170403T142318Z

                                          Dependency: entire@5.12-

                                    Dependency type: incorporate



                                    pkg://solaris/support/constraint/solaris-              2253/6437 |

                                               ERROR: Missing dependency.

                                             Package: pkg://solaris/support/constraint/solaris-,5.11:20170320T151542Z

                                          Dependency: entire@5.12-

                                    Dependency type: incorporate




                                    1 2 3 Previous Next