6 Replies Latest reply on Apr 6, 2018 2:39 PM by Christian Berg

    User cannot edit the analyses (despite correct permissions) [OBIEE]



      One of our users cannot edit analyses, even in his home catalog he can only open analysis, he can't edit it. We use windows AD authentication with OBIEE. This user (user_n1 in this case) is a member of BIAuthors group in AD (group containing users with BI Author role, so they can create, edit an run reports and analyses). From weblogic console I can see, that user_n1 is correctly assigned to equal group (BIAuthors). After successfully login to OBIEE Publisher this user on home page can only open dashboards or analyses visible on Recent panel (under every dashboard or analysis there is no edit option, only open and more options). Also in the common Header area there is no Catalog link, on the left side of this page there is no Browse / Manage... section too. It looks like this user has read permissions only, but why?


      I compared from administrator level permissions of this user (user_n1) with another user (user_n2 - this user can edit analyses without any problems). User_n2 has identical permissions (I mean permissions to their home catalog and shared folder) as user_n1 (he also is assigned to BIAuthors group). User_n2 after login to OBIEE Publisher can see all edit options on the home page, which are not visible for user_n1, also he can see Catalog link in the common Header area and Browse / Manage... section too.


      I tried remove user_n1 from BIAuthors group from AD level and put him again, restart OBIEE services, but with no result. Other 39 users from BIAuthors group can edit analyses without any problems, only this one (user_n1) cannot, despite the fact, he has identical permissions (based on BI Author role) as other users. I tried get full control permission to home catalog for user_n1 (recursively to all elements located in this catalog), and still nothing, when user_n1 opens his home catalog (only way to do this is entrance by url adress .../analytics/saw.dll?catalog, there is no any other possibility to get into this catalog for this user), there are still only open and more options, with no edit option.


      I have no idea, what may cause of this problem. I've been sitting with this on few days and still nothing...


      Any help appreciated. Thank you!