10 Replies Latest reply on Sep 26, 2006 2:16 PM by 392393

    [SOLVED] oracle xe on gentoo - no web interface

      After a long and annoying process of trial and error I've managed to install Oracle XE on Gentoo Linux. Now the problem is I can't access the web interface.
      kenjiru radu # ps -ef | grep tnslsnr
      oracle    9416     1  0 15:02 ?        00:00:00 /usr/lib/oracle/xe/app/oracle/product/10.2.0/server/bin/tnslsnr LISTENER -inherit

      kenjiru radu # ps -ef | grep XE
      oracle    9421     1  0 15:02 ?        00:00:00 xe_pmon_XE
      oracle    9423     1  0 15:02 ?        00:00:00 xe_psp0_XE
      oracle    9425     1  0 15:02 ?        00:00:00 xe_mman_XE
      oracle    9427     1  0 15:02 ?        00:00:00 xe_dbw0_XE
      oracle    9429     1  0 15:02 ?        00:00:00 xe_lgwr_XE
      oracle    9431     1  0 15:02 ?        00:00:00 xe_ckpt_XE
      oracle    9433     1  0 15:02 ?        00:00:02 xe_smon_XE
      oracle    9435     1  0 15:02 ?        00:00:00 xe_reco_XE
      oracle    9437     1  0 15:02 ?        00:00:00 xe_mmon_XE
      oracle    9439     1  0 15:02 ?        00:00:00 xe_mmnl_XE
      oracle    9443     1  0 15:03 ?        00:00:00 xe_qmnc_XE
      oracle    9495     1  0 15:03 ?        00:00:00 xe_q000_XE

      kenjiru radu # cat /etc/default/oracle-xe|grep HTTP_PORT

      kenjiru radu # netstat -anl | grep 8088
      So oracle isn't listening on port 8088.

      This is the first time I've installed Oracle on Linux so it is possible I've done something wrong, but I can't figure out where the problem is.

      During installation process I've created a new database like this:

      1. modified ORACLE_SID=XE
      2. cp $ORACLE_HOME/dbs/init.ora $ORACLE_HOME/dbs/initXE.ora
      3. sqlplus '/ as sysdba'
      4. SQL> create database XE;

      So I can start oracle like this:
      kenjiru ~ # /etc/init.d/oracle start
      * Starting Oracle Net Listener ...

      LSNRCTL for Linux: Version - Production on 23-SEP-2006 15:02:49

      Copyright (c) 1991, 2005, Oracle.  All rights reserved.

      Starting /usr/lib/oracle/xe/app/oracle/product/10.2.0/server/bin/tnslsnr: please wait...

      TNSLSNR for Linux: Version - Production
      System parameter file is /usr/lib/oracle/xe/app/oracle/product/10.2.0/server/network/admin/listener.ora
      Log messages written to /usr/lib/oracle/xe/app/oracle/product/10.2.0/server/network/log/listener.log
      Listening on: (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=localhost,)(PORT=1521)))

      STATUS of the LISTENER
      Alias                     LISTENER
      Version                   TNSLSNR for Linux: Version - Production
      Start Date                23-SEP-2006 15:02:49
      Uptime                    0 days 0 hr. 0 min. 0 sec
      Trace Level               off
      Security                  ON: Local OS Authentication
      SNMP                      OFF
      Default Service           XE
      Listener Parameter File   /usr/lib/oracle/xe/app/oracle/product/10.2.0/server/network/admin/listener.ora
      Listener Log File         /usr/lib/oracle/xe/app/oracle/product/10.2.0/server/network/log/listener.log
      Listening Endpoints Summary...
      Services Summary...
      Service "XE" has 1 instance(s).
        Instance "XE", status UNKNOWN, has 1 handler(s) for this service...
      The command completed successfully                                                                                                                     [ ok ]
      * Starting Oracle Database 10g Express Edition Instance ...
      ORACLE instance started.

      Total System Global Area   96468992 bytes
      Fixed Size                  1257356 bytes
      Variable Size              88080500 bytes
      Database Buffers            4194304 bytes
      Redo Buffers                2936832 bytes
      Database mounted.
      Database opened.
      1. How can I check if the database is really ok?
      2. And why the web interface doesn't work?

      Message was edited by:
        • 1. Re: oracle xe on gentoo - no web interface
          Try the following and then see if you can connect from another computer:

          Enabling Remote HTTP Connection with SQL Command Line

          1.Start SQL Command Line and connect to the database as user SYSTEM. Provide the SYSTEM password that you assigned upon installation (Windows) or configuration (Linux) of Oracle Database XE.See "Connecting Locally with SQL Command Line" on page 3-6 or "Connecting Remotely with SQL Command Line" on page 3-7 for instructions.

          2.At the SQL Command Line prompt, enter the following command:EXEC DBMS_XDB.SETLISTENERLOCALACCESS(FALSE);

          • 2. Re: oracle xe on gentoo - no web interface
            The default port is 8080
            Can you connect with SQL*Plus ?

            • 3. Re: oracle xe on gentoo - no web interface
              Yes, I can connect with Sql*Plus, athough I don't have a database yet. I have an ORACLE_SID=XE and I've created a database with the command "create database XE" from within Sql*Plus.
              radu@akira ~ $ sqlplus '/ as sysdba'

              SQL*Plus: Release - Production on Sun Sep 24 00:18:20 2006

              Copyright (c) 1982, 2005, Oracle.  All rights reserved.

              Connected to:
              Oracle Database 10g Express Edition Release - Production


              ERROR at line 1:
              ORA-06553: PLS-213: package STANDARD not accessible
              What should I do now?
              • 4. Re: oracle xe on gentoo - no web interface
                I haven't used Gentoo for a couple of years and have never installed Oracle on it. If you just want to get XE up and going may I suggest CentOS or Ubuntu?

                From memory, nothing was easy or simple with Gentoo.
                Typing this error into Google resulted in several hits such as:

                9i install error ORA-06553: PLS-213: package STANDARD not accessible

                Good luck.
                • 5. Re: oracle xe on gentoo - no web interface
                  It's not a production server. I want to install Oracle XE on my desktop as I need it for school. And I won't change my distribtuion just to install Oracle!

                  I'm missing something here, but I think I'm very close to solving the problem.
                  • 6. Re: oracle xe on gentoo - no web interface
                    XE creates the database when you run /etc/init.d/oracle-xe configure

                    You don't need to create the database manually, in fact, I'd highly recommend against it. Register your download of XE and there's a wealth of resources available in the Oracle XE forum.

                    • 7. Re: oracle xe on gentoo - no web interface
                      /etc/init.d/oracle-xe configure does not create any database. But I've managed to create a database manually and it works quite well. Of course the hole process was a pain, but in the end it worked fine. Now the only problem is why the web interface still doesn't work...

                      I guess I'll try the XE forum.
                      • 8. Re: oracle xe on gentoo - no web interface
                        If you created the database manually, you're missing the APEX installation from the seed db that is used during the installation, which represents said web interface. Scripts for installing APEX afterwards are not available for XE!

                        • 9. Re: oracle xe on gentoo - no web interface
                          I've finally solved the problem, I got the web interface up and running. Here is what I did (clean install):

                          - extracted the contents of the rpm
                          - created users, changed permissions
                          - edited /etc/init.d/oracle-xe commenting the line witch deletes $ORACLE_HOME/config/seeddb
                          - edited $ORACLE_HOME/config/scripts/init.ora and $ORACLE_HOME/config/scripts/initXETemp.ora and replaced the following variables:
                          - run /etc/init.d/oracle-xe configure and followed the instructions; now this takes a while, as it should

                          Now a little piece of advice for everybody out there who is as desperate as I was: - environment variables are very important, you should check them every time you get into trouble
                          - user permissions are also important, all files in $ORACLE_HOME should be owned by the oracle user, group "dba"
                          • 10. Re: [SOLVED] oracle xe on gentoo - no web interface
                            Thanks for coming back and posting the solution :) That always helps to add to our collective knowledge.