1 Reply Latest reply on Sep 3, 2018 1:01 PM by thatJeffSmith-Oracle

    SQL Developer with SSL on AWS Cloud connection > failed with I/O-Fehler: General SSLEngine problem

    Tobias Arnhold

      Hi,

       

      I'm trying to connect to a Oracle database in the amazon AWS cloud via SQL developer.

      Unfortunately I consistently fail with different connection errors

      Bei der Ausführung des angeforderten Vorgangs ist ein Fehler aufgetreten:

      I/O-Fehler: General SSLEngine problem, connect lapse 629 ms., Authentication lapse 0 ms.

      Herstellercode 17002

       

      Another connection error I had:

      Handshake error

       

      I tried to follow this example and a few others:

      https://docs.aws.amazon.com/AmazonRDS/latest/UserGuide/Appendix.Oracle.Options.SSL.html#Appendix.Oracle.Options.SSL.JDBC

       

      Current JDK version: Build 1.8.0_181-b13

      Current SQL Developer version:  Version 18.2.0.183

      I'm working under Mac OSX El Captain: 10.11.6

       

      I also tried to install the certificates over the Java GUI but didn't help either:


      Can't install on System and I get an password error when I try to upload it unter "User">"client authentication".

       

      I'm out of ideas...

       

      Thanks ahead,

       


      Tobias Arnhold