2 Replies Latest reply on Mar 28, 2019 3:50 PM by Christian Lupprich-Oracle

    Simphony 18.2 Engagement APP login error

    Sven Keleuva

      Dear Team,


      Has anyone tried to enable Engagement feature in 18.2?


      I'm trying to setup Engagement feature in my local Simphony 18.2 test environment.

      When I try to login to EngagementApp I get Service threw an internal error message.

      Looking at Micros.Engage.Config.log I found error message:

      Micros.Engage.Config ErrorCode: Error occured while communicating with the EMC authentication service. ERR_GENERIC_ERROR

      and by looking at Micros.Simphony.Ws.log there is following error:


      [ERROR ] 2019-03-28 10:41:24,258 [10] Micros.EMCWeb.WebService ErrorCode: ERR_GENERIC_ERROR. dac7c912 Exception Summary:


      UTC Timestamp: 03/28/2019 09:41:24.246

      Machine Name: SIMPH-APP02


      Assembly Full Name: Micros.EMCWeb.Logging, Version=, Culture=neutral, PublicKeyToken=null

      Assembly Version:

      App Domain Name: /LM/W3SVC/2/ROOT/WS-1-131982396828451274

      Application Base Path: D:\MICROS\Simphony2\Engagement\WS\

      Windows Identity: IIS APPPOOL\WCCPool


      Exception Information Details:


      Exception Type: System.ArgumentException

      Message: The path is not of a legal form.

      Help Link:

      HResult: -2147024809

      Param Name:

      Source: mscorlib

      Target Site: System.String NewNormalizePathLimitedChecks(System.String, Int32, Boolean)


      OS: Windows Server 2016

      DB: Oracle

      Simphony version 18.2 HF1


      Same error is reproduced in a separate environment, also on v18.2 but without HF1.