11 Replies Latest reply on Aug 10, 2019 11:26 AM by Gianni Ceresa

    Unable to access anything related to OBIS

    Adam Wickes

      Hi all,


      We seem to have an issue with our windows install.
      The first indication was that we could no longer log in presentation services.




      After checking EM, I noticed that everything all looked fine in there so I decided to restart the server and see if that would help.
      Nothing changed.


      I then attempted to login to the online rpd using the admin tool and got the following error:




      My next thought was that the rpd might be corrupt so I attempted to use datamodel.cmd to upload an rpd that I knew worked.



      I then confirmed that the port was indeed open and that everything was running correctly which it was.


      I have checked most logs... the most interesting being bi_server1-diagnostic.


      [2019-08-08T18:14:40.405+10:00] [bi_server1] [NOTIFICATION] [] [oracle.bi.utilitycomm.SocketPool4$SocketPoolClient] [tid: pool-113-thread-1] [userId: weblogic] [ecid: 05c88e1b-7cb5-450d-8868-d11f732d7370-0000061f,0:107] [APP: bi-lcm-rest] [partition-name: DOMAIN] [tenant-name: GLOBAL] [SI-Key: ssi] maxTry=3,i=2,oracle.bi.utilitycomm.ObjectPoolCreateException: create object failed java.net.ConnectException: Connection refused: connect[[

        at oracle.bi.utilitycomm.SocketPool4$SocketPoolClient.create(SocketPool4.java:246)

        at oracle.bi.utilitycomm.ObjectPoolFactory.createObjects_locked(ObjectPoolFactory.java:117)

        at oracle.bi.utilitycomm.ObjectPoolFactory.getObject(ObjectPoolFactory.java:169)

        at oracle.bi.utilitycomm.SocketPool4$SocketPoolClient.getObject(SocketPool4.java:254)

        at oracle.bi.utilitycomm.SocketPool4$SocketPoolClient.getFreeRpcClient(SocketPool4.java:302)

        at oracle.bi.utilitycomm.SocketPool4.getFreeRpcClient(SocketPool4.java:409)

        at oracle.bi.jdbcclient.TcpClientAPI.callRPC(TcpClientAPI.java:55)

        at oracle.bi.jdbcclient.TcpClientAPI.OpenServer(TcpClientAPI.java:169)

        at oracle.bi.jdbcclient.TcpClientAPI.OpenSession(TcpClientAPI.java:98)

        at oracle.bi.jdbc.AnaJdbcConnection.<init>(AnaJdbcConnection.java:120)

        at oracle.bi.jdbc.AnaJdbcDriver.connectToNQSNode(AnaJdbcDriver.java:399)

        at oracle.bi.jdbc.AnaJdbcDriver.connect(AnaJdbcDriver.java:460)

        at java.sql.DriverManager.getConnection(DriverManager.java:664)

        at java.sql.DriverManager.getConnection(DriverManager.java:208)

        at oracle.bi.jdbc.AnaJdbcDataSourceImpl.getConnection(AnaJdbcDataSourceImpl.java:28)

        at oracle.bi.jdbc.AnaJdbcDataSourceImpl.getConnection(AnaJdbcDataSourceImpl.java:38)

        at oracle.bi.server.customization.utils.BiProcedureExecutor.getConnection(BiProcedureExecutor.java:437)

        at oracle.bi.server.customization.utils.BiProcedureExecutor.uploadRpdProcedure(BiProcedureExecutor.java:463)

        at oracle.bi.server.customization.utils.UploadBinRpdTaskCSS.execute(UploadBinRpdTaskCSS.java:265)

        at oracle.bi.server.customization.utils.CallableProgress.call(CallableProgress.java:37)

        at oracle.bi.server.customization.utils.UploadBinRpdTaskCSS.call(UploadBinRpdTaskCSS.java:33)

        at oracle.bi.server.customization.utils.CallableProgress.call(CallableProgress.java:12)

        at java.util.concurrent.FutureTask.run(FutureTask.java:266)

        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)

        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)

        at java.lang.Thread.run(Thread.java:748)




      [2019-08-08T18:14:40.405+10:00] [bi_server1] [WARNING] [] [oracle.bi] [tid: pool-113-thread-1] [userId: weblogic] [ecid: 05c88e1b-7cb5-450d-8868-d11f732d7370-0000061f,0:107] [APP: bi-lcm-rest] [partition-name: DOMAIN] [tenant-name: GLOBAL] [SI-Key: ssi] java.net.ConnectException: Unable to connect to port 9517 on machine xxxxxx.


      The logs also seem to be littered with the below error but not sure if it's relevant given we're not running in a cluster.
      We are however using Singleton Data Directory and Global Cache but everything seems to be ok with that. No permission issues etc.




      The only thing I can think of that may have caused this is the following:


      This morning, I attempted to use "export_service_instance" as I wanted to migrate the catalog to another machine.
      It failed due to not knowing what the BI_PRODUCT_HOME was.
      I then compared the environment variables on the bad machine vs another machine that I knew worked and noticed that the good machine didn't reference ORACLE_HOME, DOMAIN_HOME, BITOOLS_HOME etc etc
      Sooooo... Perhaps stupidly, I took notes of what the env var values were, deleted them and restarted the app.


      I then re-tried the export process again and it was around this time where something happened I believe.
      Now for the really stupid part.... My first reaction was to restart the server to see if that would fix it... Unfortunately, I didn't save the note specifying the env vars.... *sigh*.


      Anyway... that's my full disclosure. Some pretty dumb maneuvers on my part so try not to kick me too hard while i'm down.
      I just want this bloody thing fixed.


      Appreciate any help that you guys can give me.


      PS Would just like to re-iterate that I have restarted about 20 times now and every time, it comes up perfectly with no issues. In EM, everything is green. Just cannot access the rpd and therefore, OBIPS.