1 Reply Latest reply on Aug 13, 2019 10:26 PM by Erik - Hotspot Engineer-Oracle

    Java Flight Recorder reports events that are 4+ years old?


      Although this question is probably more to do with Java Flight Recorder than Mission Control I could not find a specific JFR space so thought I would try here.


      My issue has to do with JFR seemingly logging (finding?) event data that is excessively old and I cannot figure out why.  For some reason when I enable JFR I seemingly get events from years ago.  I came across this article (https://blogs.oracle.com/poonam/clarifying-some-confusion-around-java-flight-recordings ) and it does make sense that JFR might pick up some events that occur before you actually start recording.  But I cannot understand how one can start a JVM with JFR enabled and have events with a timestamp of more than 4 years prior to that JVM being started.  All machine's dates are set properly (and I have reproduced this behavior on a server with ntpd running). I have checked for logs in the user's <home directory>/.java.  I've also cleared out /var/logs.  I've tried installing a fresh version of the JDK and have tried with both JDK 8 and 11.  I've also tried loading the JFR recording data in two different Mission Control apps (Oracle and Azul's Zulu).


      Here are some screen captures showing the data I see:

      Screen Shot 2019-07-11 at 3.06.32 PM.png

      Screen Shot 2019-07-11 at 3.03.23 PM.png

      Screen Shot 2019-07-11 at 3.03.00 PM.png

      Note that the JVM start time listed is correct (today's date) and yet somehow events span 229 weeks and 5 days?  If anyone has any ideas let me know because my Googler is very worn out at present...