1 2 3 Previous Next 33 Replies Latest reply on Sep 10, 2019 3:21 PM by ClaudiuO-Oracle

    Does Latest BIOS support 5600 Cpu's on X4270 M1

    4063717

      hello.

      I have purchased an old X4270 M1 server for a hobby project.

      An Ebay purchase, but was told to be working.

      I can login to ILOM and see no faults with the unit, but can not get it to show a BIOS boot screen when powered on. it never gets a solid green power light.

       

      I have check all the hardware and it looks great. but in doing so, found Xeon 5650's in it. all the Docs say this server only supports 5500 cpu's.

      did a later BIOS update add support for the 5650's?

      or did someone try to upgrade it, fail and just flog it off?

       

      any help would be appreciated.

       

      the SP says no P0,P1 fault. it says ok....

       

      also, could the onboard display be disabled/ faulty?

       

      current ILOM version is 3.0.6.10.

        • 1. Re: Does Latest BIOS support 5600 Cpu's on X4270 M1
          ClaudiuO-Oracle

          Hello

           

          May I also suggest you change your display name from the default to something more user friendly. See details here: https://community.oracle.com/docs/DOC-1022508

           

          Regarding your issue, that is an interesting story, the only CPU's certified to be installed on the Sun Fire X4270 server as per Oracle System Handbook (https://support.oracle.com/handbook_private/Systems/SunFireX4270/components.html#CPUModule ) are:

           

          2.93GHz Intel Quad-Core Xeon X5570, 8MB, 95W

          2.80GHz Intel Quad-Core Xeon X5560, 8MB, 95W

          2.53GHz Intel Quad-Core Xeon E5540, 8MB, 80W

          2.26GHz Intel Quad-Core Xeon L5520, 8MB, 60W

          2.26GHz Intel Quad-Core Xeon E5520, 8MB, 80W

           

          Therefor the Xeon 5650 is not on the list.

           

          The firmware upgrade won't help here, you could try to upgrade to the latest available: Patch 28398445: X4170 SW 2.8.1 - ILOM AND BIOS which contains Oracle ILOM 3.2.11.20.b and BIOS 07.06.03.20 but I don't think it will help.

           

          The Xeon X56** series is available for the M2 version of Sun Fire X4*70.

           

          Out of curiosity can you please provide me the following outputs from SP?

           

          -> show /SYS

          -> show /SYS//MB/P0

          -> show /SYS//MB/P1

           

          Regarding your last question (also, could the onboard display be disabled/ faulty?) you can monitor the server boot process using the serial console or the Java Remote console (start /SP/console after powering on the system with start /SYS or launch Redirection from ILOM web interface, Remote control tab)

           

          I hope this helps.

           

          Best regards,

          Claudiu

           

          MOSC Community Moderator

          1 person found this helpful
          • 2. Re: Does Latest BIOS support 5600 Cpu's on X4270 M1
            4063717

            well ,apart for all the targets at the top and commands at the bottom, the outputs are as follows.

             

            show /SYS gave

            Properties:

                    type = Host System

                    ipmi_name = /SYS

                    product_name = SUN FIRE X4270 SERVER

                    product_part_number = 602-4665-02

                    product_serial_number = 0921XF700C

                    product_manufacturer = SUN MICROSYSTEMS

                    fault_state = OK

                    clear_fault_action = (none)

                    power_state = Off

             

            show /SYS/MB/P0 gave

             

            Properties:

                    type = Host Processor

                    ipmi_name = MB/P0

                    fault_state = OK

                    clear_fault_action = (none)

             

            and show /SYS/MB/P1 gave

             

            Properties:

                    type = Host Processor

                    ipmi_name = MB/P1

                    fault_state = OK

                    clear_fault_action = (none)

             

            when i said i checked the hardware, i meant i removed, cleaned, reseated and added new thermal paste the the CPU's. they are marked 5650's

             

            but when i type start /SYS, i get the fast flash of power led, but no image on my screen.

            • 3. Re: Does Latest BIOS support 5600 Cpu's on X4270 M1
              ClaudiuO-Oracle

              Hello ,

               

              The server was originally shipped with X5570 CPU's which means that someone at some point in time has tried to perform an upgrade, to make it more complicated Sun/Oracle never sold this type of CPU Intel Xeon X5650 in X64 systems as per my findings, so we don't have any experience if this would actually work or not in a certified configuration.

               

              The show /SYS/MB/Px output should look like this:

               

              Properties:

                      type = Host Processor

                      ipmi_name = MB/P0

                      fru_name = Intel(R) Xeon (R) CPU           X5650 @ 2.66GHz

                      fru_version = **

                      fru_part_number = ****

                      fault_state = OK

                      clear_fault_action = (none)

               

              The 4170/4270 architecture is based on Intel Tylersburg-EP Platform supporting Nehalem-EP Processor while 4170M2/4270M2 introduced the Intel’s Westmere-EP CPU

               

              I've seen a lot of similar servers on eBay with X56** series and they all seem custom configured systems.

               

              Have you tried using the serial console or the java remote console instead of the VGA port to see the boot process?

               

              Best regards,

              Claudiu

              1 person found this helpful
              • 4. Re: Does Latest BIOS support 5600 Cpu's on X4270 M1
                4063717

                could the "fru" lines be part of a later ILOM firmware?

                 

                i don't have a serial cable, but will look into buying/making one, so i haven't tried watching the boot process that way. (wouldn't that be so slow? or is it a text based boot sequence?)

                 

                however, i have tried to bring up ILOM via web browser in order to try that, but all i get is:

                 

                Access Error


                Site or Page Not Found

                Cannot open URL

                 

                however, the web address line has "home.asp" after the IP address, so it has found the server, just not the ILOM page.

                 

                i'm wondering if i have a corrupt BIOS/ILOM....

                • 5. Re: Does Latest BIOS support 5600 Cpu's on X4270 M1
                  ClaudiuO-Oracle

                  Hello

                   

                   

                   

                   

                   

                   

                   

                  1 person found this helpful
                  • 6. Re: Does Latest BIOS support 5600 Cpu's on X4270 M1
                    4063717

                    version gives:

                    SP firmware 3.0.6.10

                    SP firmware build number: 48729

                    SP firmware date: Mon Sep 28 21:20:33 EDT 2009

                    SP filesystem version: 0.1.22

                     

                    and show /SYS/MB/BIOS gives:

                    Properties:

                            type = BIOS

                            ipmi_name = MB/BIOS

                     

                    show /SP/services/http gives:

                    Properties:

                            port = 80

                            secureredirect = disabled

                            servicestate = enabled

                     

                    yet i get that "access error" i said before. when going to my server via web browser.

                     

                    however, for the first time... (must have typed it quick enough)

                    when i ran start /SYS, then Start /SP/console i got DIMM slot info pop up. then it hangs.

                     

                     

                    i really feel i need to buy a couple of 5570's and try again. I've found them for $24 on ebay for the pair. out of China though...

                    • 7. Re: Does Latest BIOS support 5600 Cpu's on X4270 M1
                      ClaudiuO-Oracle

                      Hello ,

                       

                      Show /SYS/MB/BIOS should have sown the BIOS version, example:

                       

                      /SYS/MB/BIOS

                          Targets:

                       

                          Properties:

                              type = BIOS

                              ipmi_name = MB/BIOS

                              fru_name = SYSTEM BIOS

                              fru_description = SYSTEM BIOS

                              fru_manufacturer = AMERICAN MEGATRENDS

                              fru_version = 07060315

                              fru_part_number = AMIBIOS8

                       

                      in your case it is not, so at this stage I would go for a firmware reflash (same firmware version) or upgrade to the latest revision as the fru information is not displayed properly on multiple targets (see CPU as well)

                       

                      Http is indeed enabled, what about https?

                       

                      About the POST hanging at the DIMM initialization / count you could strip the system to minimum configuration (one DIMM per each CPU as per DIMM population rules), this is an indicator that something is wrong (CPU has the memory controller embedded in it) in this case the memory could not initialize properly due to the incorrect CPU's installed, poorly seated or defect DIMM's etc.

                       

                      I don't know what to say about the products bought from ebay, there is a risk for each purchase.

                       

                      I hope the above helps.

                       

                      Best regards,

                      Claudiu

                      1 person found this helpful
                      • 8. Re: Does Latest BIOS support 5600 Cpu's on X4270 M1
                        4063717

                        scratch that. just bought 2 from Victoria. so i can test further in a few days.

                        • 9. Re: Does Latest BIOS support 5600 Cpu's on X4270 M1
                          ClaudiuO-Oracle

                          Hello 4063717,

                           

                          Let me know how it goes.

                           

                          Best regards,

                          Claudiu

                          • 10. Re: Does Latest BIOS support 5600 Cpu's on X4270 M1
                            4063717

                            Yes, you have been very helpful. my only problem now is getting a copy of the firmware that is installed to reflash it. since it's behind a pay wall.

                            i have to call about it, but suspect it will cost more than it's worth.

                            i will keep my fingers crossed that when i talk to Oracle, they may be willing to email me the currently installed version for free. but i doubt it...

                            will let you know how i go.

                            for me, it is now good night.

                            thanks for you help. Appreciate it.

                            • 11. Re: Does Latest BIOS support 5600 Cpu's on X4270 M1
                              ClaudiuO-Oracle

                              Hello 4063717,

                               

                              I am glad that I could help.

                               

                              For the firmware part I am afraid you are right.

                               

                              Have a good night,

                              Claudiu

                              • 12. Re: Does Latest BIOS support 5600 Cpu's on X4270 M1
                                4063717

                                forgot to say.

                                https is enabled. and ssl is using the defaults.

                                • 13. Re: Does Latest BIOS support 5600 Cpu's on X4270 M1
                                  ClaudiuO-Oracle

                                  Hello 4063717,

                                   

                                  That is good, so you should have access to the web interface with no problems, unless you have some ports blocked by firewall (depending on your setup).

                                   

                                  You could alternatively try to make a back-to-back connection with your laptop using a network cable and give it a try.

                                   

                                  Best regards,

                                  Claudiu

                                  • 14. Re: Does Latest BIOS support 5600 Cpu's on X4270 M1
                                    4063717

                                    unfortunately, that's not happening. i can't get anymore that the access error thru my browser. even with my AV and Firewall disabled.

                                     

                                    i will try the new CPU's and try again when they arrive.

                                     

                                    I'm just hoping Oracle will either send me the current firmware free or allow a one time buy to re-flash it.

                                    calling them now.

                                    1 2 3 Previous Next