5 Replies Latest reply on Mar 26, 2020 10:33 AM by user2685436

    Oracle 18c XE - Win10 Pro - installation hangs

    3495729

      Hello,

       

      I am trying to install Oracle 18c XE on Win10 Pro with admin privileges and at about 90-95% progress, it just hangs ("Creating Oracle XE Database")... even when i cancel the operation, after i confirm that i want to cancel it, it doesn't do anything, so the only way to interrupt it is by ending the task. Afterwards, if i try to run the installer again, it says that Oracle is already installed, so i have to uninstall it manually (delete Oracle Win registers, Oracle home directory, Windows user/groups).

      I've checked the previous conversations regarding this issue, applied the possible solutions (NetBIOS enabled) and still i get the same result.

       

      Can you please advice what should i try to solve/get around this problem?

      Please let me know if i need to attach any logs.

       

      All the best,

      Andrei

        • 1. Re: Oracle 18c XE - Win10 Pro - installation hangs
          L. Fernigrini

          From what you say, the software installation runs OK (the product) is installed but the DB creation is somehow hanging.

           

          You can try installing again and include the database alert log, it may show any serious error that may occur, or review if any trace file is generated.

          • 2. Re: Oracle 18c XE - Win10 Pro - installation hangs
            3495729

            Hi,

             

            Thanks for your interest.

            I've checked the database alert logs and ORA-00445 pops-up:

             

            alert_xe.log

            "

            2020-01-23T14:52:29.135087+02:00

            Errors in file C:\APP\USER1\PRODUCT\18.0.0\diag\rdbms\xe\xe\trace\xe_mmon_12924.trc  (incident=20555) (PDBNAME=CDB$ROOT):

            ORA-00445: background process "M000" did not start after 120 seconds

            2020-01-23T14:54:34.237803+02:00

            Errors in file C:\APP\USER1\PRODUCT\18.0.0\diag\rdbms\xe\xe\trace\xe_aqpc_11892.trc  (incident=20552) (PDBNAME=CDB$ROOT):

            ORA-00445: background process "QM03" did not start after 120 seconds

            2020-01-23T14:56:39.326552+02:00

            Errors in file C:\APP\USER1\PRODUCT\18.0.0\diag\rdbms\xe\xe\trace\xe_mmon_12924.trc  (incident=20556) (PDBNAME=CDB$ROOT):

            ORA-00445: background process "MZ01" did not start after 120 seconds

            "

            xe_mmon_12924.trc

            "

            *** 2020-01-23T15:05:08.482150+02:00 (CDB$ROOT(1))

            calling location                         entry point                              arg #1           arg #2           arg #3           arg #4         

            ---------------------------------------- ---------------------------------------- ---------------- ---------------- ---------------- ----------------

            00007FFA9337F7E4                         0000000000000000                         0000000000000000 00007ffa93321563 0000000000000000 0000000000000000

            00007FFA9331D815                         00007FFA9337F7D0                         0000000000000000 0000000000000000 0000000000000000 0000000000000000

            00007FFA933267C7                         00007FFA9331D6B8                         0000000000000000 0000000000000000 0000000000000000 0000000000000000

            00007FFA93355765                         00007FFA9332673C                         0000000000000000 0000000000000000 0000000000000000 0000000000000000

            00007FFA933556C3                         00007FFA933556DC                         0000000000000000 ffffffff932e0000 0000000000000000 0000000000000000

            00007FFA9335566E                         00007FFA93355688                         0000000000000000 0000000000000000 0000000000000000 0000000000000000

            ---------------- End of Call Stack Trace -----------------

            Call stack acquisition performance stats:

              setup time (lock acquis., memory alloc.): 0 ms

              frame get time (time the target proc was suspended): 0 ms

              symbol translation time: 0 ms

              total time: 0 ms

            DDE: Problem Key 'ORA 445' was flood controlled (0x4) (incident: 20558)

            ORA-00445: background process "MZ01" did not start after 120 seconds

            "

             

            xe_aqpc_11892.trc

            "

            *** 2020-01-23T15:03:00.229499+02:00

            DDE: Problem Key 'ORA 445' was flood controlled (0x4) (incident: 20562)

            ORA-00445: background process "QM03" did not start after 120 seconds

            "

             

            I don't know what i need to do next, so if anything comes in mind, please share

             

            I've checked this thread https://community.oracle.com/thread/4206522, but it isn't my case.

             

            All the best,

            Andrei

            • 3. Re: Oracle 18c XE - Win10 Pro - installation hangs
              Billy~Verreynne

              There are support notes on this error:

              • Master Note: Troubleshooting Oracle Background Processes (Doc ID 1509616.1)
              • Troubleshooting Guide (TSG) - Ksvcreate: Process(xxxx) Creation Failed / ORA-00445: Background Process "xxxx" Did Not Start After n Seconds (Doc ID 1379200.1)

               

              If you are technically inclined, troubleshoot by setting trace 10281 via custom pfile and do a manual db start.

               

              If you are logically inclined, change from Windows to Linux. Exchange dirty and convoluted complexity for the elegance of simplicity.

              • 4. Re: Oracle 18c XE - Win10 Pro - installation hangs
                Christian.Shay -Oracle

                Please disable anti-virus and try again.

                 

                I think you said you have seen this list of common issues, but just to be sure:

                 

                1) Is ORACLE_HOME or TNS_ADMIN set in the environment? Go to a command prompt, type "set". You will need to temporarily unset any such environment variables.

                 

                2) Are you using Windows 10 Home Edition? It is not supported and the installer is not properly checking for it in the Prerequisite check.

                 

                3) Are you using Server 2019? Same issue.

                 

                4) On your network adapter that you are using, check (enable) "Client for Microsoft Networks" and "File and Printer Sharing for Microsoft Networks".

                 

                5) Check to make sure Netbios is enabled on your network connection:

                See this link for more info:

                 

                 

                http://ecross.mvps.org/howto/enable-netbios-over-tcp-ip-with-windows.htm

                 

                 

                6) In some cases, antivirus has interfered with an installation.  Try installing without AV.

                 

                 

                7) Try creating a local user and adding to local administrator group and then log in and install as that user.

                • 5. Re: Oracle 18c XE - Win10 Pro - installation hangs
                  user2685436

                  Hi all

                   

                  I tried to install express 18c on Win 10 HOME and Win10 PRO and it was hanging at about 90-95% progress also.

                  The way I did to bypass this issue, working as well as for Win 10 Home as for Pro : all is about administrator account !

                  What I did :

                       log to win 10 using the usual account and run cmd.exe (as administrator) and issue : net user administrator /active:yes

                       log to win 10 with the real administrator account and run the 18xe setup.exe (no need to run as administrator). Then the install achieved well. Give full access to folder (and all sub-folders and sub-files)18xe was installed in to the win 10 usual account

                      log to win 10 using the usual account and run cmd.exe (as administrator) and issue : net user administrator /active:no

                  Then I was able to use the 18xe from my usual account ...

                   

                  I hope this will help someones