1 Reply Latest reply on May 7, 2020 9:40 PM by lmu

    Function not available to this responsibility

    lmu EBS database - Clone

      custom form

      error when trying to access 'Function not available to this responsibility'.


      This form works in the source.  Does not work in the new target.


      I found this note: Custom Form: Function not Available to this Responsibility (Doc ID 1079951.1)

      But i don't understand what it wants me to do.


      Oracle Application Object Library - Version 11.5.2 to 12.1.3 [Release 11.5 to 12.1]

      Information in this document applies to any platform.


      Navigation steps:
        Select Custom Responsibility, Navigate to Custom Form


      When selecting custom form following error occurs:
         Function not available to this responsibility




      The CUSTOM_TOP value is not defined correctly in the environment.


      1)  Login to applications and try to open the custom Form.

      2)  Navigate to Help --> Diagnostics --> Examine.  Click the "Examine Fields and variable values"

      3) Populate the field with the next values:

      FIELD --> (For example XXCUS1_TOP) ( this does not have anything resembling the custom top as an option in the target or source)


      4)  Push tab key and check that the variable is defined and that the VALUE is correct.

      If the variable is not correctly defined, then:

      1)  Review application environment file to check and correct variable definition. (which application env file?))

      2)  If using servlet mode, then check the definition in the file $IAS_CONFIG_HOME/Apache/Jserv/etc/formservlet.ini . I don't see the definition. It doesn't seem like this custom schema is registered in source or target.

        • 1. Re: Function not available to this responsibility

          This was on a cloned instance. Neither adcfgclone nor autoconfig created the custom env  file. The file was there from the source but it was not named for the target host. I updated the name of the file to the target host name.  sourced the .bash_profile and restarted the apps tier.  This resolved the issue.


          The custom env file is here: