7 Replies Latest reply on Apr 14, 2010 4:08 PM by user133833

    Error 1114 - again

    534862
      Hi

      I have read all other threads with respect to this error and have yet to be successful.

      We have several hundred PCs with Oracle Developer Suite 10g (9.0.4) installed and have recently met the following problem:

      A user cannot initiate the Oracle ODBC driver/connection.

      The procedure should be as follows:

      1) open Access database, get external data, link tables
      2) Scroll down thru file types and select ODBC databases
      3) Next select Machine Data Source, select oracle in OraClient10g_home1

      This errors out without option to enter Data source name or selecting TNS Service name

      Error 1114 generated and no progress can be made.

      It is not possible for a user to create a new connection either.

      I have checked the system and it would appear a change instigated by updates/security patches etc has stopped it working.



      I have read around the subject by Googling and have performed the following actions - all have failed to restore the ODBC stuff

      Checked the envoronmental variable PATH against a newly built, fully patched and functioning system....

      Installed Oracle ODBC drivers - this generates a different error 'The setup routines for Oracle Ora10105 ODBC driver could not be loaded due to system error code 127'

      Re-installed MS Office - it was suggested that this may regenerate the ODBC drivers

      Replaced the following 3 dll's - mfc71.dll, msvcrt.dll and msvcr71.dll

      Removed Microsoft's October patches

      I have run out of ideas now and NO re-installing the DevSuite is NOT an option......

      Has anyone actually resolved this issue properly??

      Please help


      Greg
        • 1. Re: Error 1114 - again
          Laurenz Albe
          There have been numerous complaints about 'Error 1114' on this forum.

          For some reasons all of these complaints have been very unspecific and confusing, and frequently the threads are interspersed with messages like 'it works for me now' while others claim that 'Instant Client is broken'.

          Your posting is rather typical. You tell about operating system patches you installed and/or removed, but you fail to give us the relevant information:

          - What is the operating system on the machine where you installed Instant Client?
          - Which version of Instant Client did you install?
          - Did you install Instant Client from the Oracle Client CD or did you use the Instant Client download? Basic or Basic Lite?
          - Is there any other Oracle Software installed on the same machine? If yes, what?
          - Which version of the database server do you use? On which operating system? Can you successfully connect to this database from any of your client machines?
          - Describe the steps you took to install Instant Client. Did you set any environment variables? Which ones? To which value?

          If you cannot remember all of this, maybe you should try it again on a clean machine, see if it works and if not, tell us what you did and all the error messages. Then somebody can have a chance to help you.

          Yours,
          Laurenz Albe
          • 2. Re: Error 1114 - again
            534862
            Hello

            For the record I have solved this.....I am not an Oracle guru....just the guy who repackages software for deployment, in this case a scripted install using SMS Installer for scripting and Microsoft SMS 2003 SP2 for deployment to about 160 PCs.

            Client PCs run Win XP Pro SP2 - fully hotfixed.....

            Oracle server is v 10.2.0....

            The problem was in fact nothing to do with Microsoft patching - there were may red herrings here, some other organisations had also thought that patching had broken their Oracle products!!

            The real issue stems from the environmental variable 'path'…..as you may be aware in Win XP the environmental variables were limited to 1023 characters and when Microsoft released Win XP Pro Service Pack 2 this was extended to 2047 characters…….

            So how does this affect the Oracle products?

            It appears that although java products are not intrinsically dependent upon the base operating system they do need a number of OS references to allow them to function correctly and consequently do make good use of environmental variables. Our version of the Oracle installers do not appear to recognise the increased size of the 'path' variable and as such fail to complete the installation when the 'path' variable exceeds 1023 characters……..having determined this back in September I designed our installers to recognise this and 'fool' the Oracle installers……this appeared to work quite well and we did achieve a successful installation of Dev Suite et al. However, I have since found that our scripting tools happen to have the same limitation as Oracle installers and as a consequence one of the path names was incomplete!!!

            This appeared simple to fix and I used other scripting tools to do this………but Developer Suite et al still failed to function correctly!!!! (Make the database connection as described in my original post)

            Quite by chance, and by this time shear desperation was kicking in, I reversed the order of the path variable, i.e. I put Dev Suite at the beginning and hey presto…..all is now well.

            So why did this problem arise…….it's actually quite simple………even with one of the path variables incomplete Dev Suite would have worked but yet another application was installed in October that again increased the length of the 'path' variable and when being read from the right hand side the Dev Suite et al entries were pushed beyond the 1023 characters…….GGgggrrrrrrr!!!

            I have tried to future proof Developer Suite et al by building a routine that periodically checks the 'path' variable and moves the Dev Suite et al entries towards the front of the queue just behind the windows entries…..so hopefully no matter how many more applications are installed the Dev Suite et al entries will always sit within the first 1023 characters…..

            I now have to revisit our installer and ensure that 'path' variables are set correctly for future installs.

            I hope this helps someone somewhere and......

            ......Oracle......it would be really great if you provided a decent installer that takes full advantage of the Windows installer technology!!

            I know that I'm guessing but I wouldn't mind betting that in excess of 80% of your clients use MS Windows of some description.

            Regards

            Greg Regan
            • 3. Re: Error 1114 - again
              spatangay
              Hello,

              I am not getting the Error 1114, however, I am simply trying to install an ODBC driver for 10g. To accomplish this, I first downloaded the odbc driver for 10g 10.2.0.2.0. The Readme notes said that I need to install the odbc driver using the Oracle Universal Installer. So I got a copy of just the OUI from our DBA. I installed the OUI 10.2. Using the installer, I installed the 10.2.0.2.0 odbc driver. The Readme notes said to look for the file "products.jar", which was not available, so I used "products.xml", and the driver installed successfully.

              The next step was to set up a ODBC DSN for this driver. When I attempted to do this, the Microsoft ODBC Administrator threw this message: The setup routines for the Oracle in Home1 ODBC driver could not be loaded due to system error code 127, followed by Could not load the setup of translator library.

              Other threads suggested that I copy the DLLs mfc71.dll, msvcrt.dll, and msvcr71.dll from my C:\Windows\System32 directory to the directory where I installed the odbc driver (C:\OraHome_1\BIN) and to ensure that C:\OraHome_1\BIN was defined under the PATH environmental variable. I followed all these instructions but to no avail - I am still getting those same messages. PLEASE HELP!!!
              • 4. Re: Error 1114 - again
                560099
                I am having the same Error 1114.

                I have Win XP service Pack 2.

                Installed InstantClient Basic, the JDBC package, ODBC package, SQL*Plus package in d:\oracle\instantclient_10_2

                Added this directory to the PATH variable (System) and the length of the PATH variable is 515 characters (not exceeding 1023)

                Added the tnsnames.ora file in d:\oracle\instantclient_10_2 directory and added the SYSTEM variable TNS_ADMIN to point to that directory.

                From the ODBC administrator, connected to the remote Oracle 10g Server without any problem.

                Tried to connect to that with my ODBC application and I get the error message
                "Specified driver could not be loaded due to system error 1114 (Oracle in instantclient10_2)

                Also I cannot find the full Oracle Client software on their website to download. Can anyone give me the exact URL. I can try to install the full client if the instantclient is not working.

                Thnx.

                Regards,
                rk
                • 5. Re: Error 1114 - again
                  560099
                  Update to the above error message I posted.

                  Uninstalled the Oracle InstantClient and installed the full Oralce client. Configured the ODBC data source and with my application I was able to connect to the Oracle server without any problem.

                  The problem is with the InstantClient version10_2.

                  I have loaded 500 MB worth of stuff and all I need is the small package of InstantClient to connect to my Oracle server.

                  Hope Oracle fixes the problem and releases a new version. Until then I guess those(unlucky folks) who have Error 1114 download the full Oracle client and the problem will be resolved.

                  Regards,
                  rk
                  • 6. Re: Error 1114 - again
                    674987
                    A reboot fixed it for me. I had just installed the full package and drivers.

                    I had the ORA-12514 (http://thetendjee.wordpress.com/2007/03/30/ora-12514-tnslistener-does-not-currently-know-of-service-requested-in-connect-descriptor/) error before.
                    • 7. Re: Error 1114 - again
                      user133833
                      Not that difficult.
                      My ODBC connection work fine before I install Oracle SOA 11g. The error 1114 occurred after installed Oracle SOA 11g, actually is 10g Express Database.

                      I had Oracle 10g Client on my desktop before, but when I installed the 10g Express Database, there was some change in PATH environment variable , "C:\oraclesoa\app\oracle\product\10.2.0\server\bin;" was added before the "C:\oracle\product\10.2.0\client_1\bin;", so I just try remove the "C:\oraclesoa\app\oracle\product\10.2.0\server\bin;", and do a ODBC connect again, it workes, 1114 is gone, same result when I putting "C:\oraclesoa\app\oracle\product\10.2.0\server\bin;" after "C:\oracle\product\10.2.0\client_1\bin;". So the only issue is put "C:\oraclesoa\app\oracle\product\10.2.0\server\bin;" front.

                      This is easy to explain, when connect oracle by ODBC, it call the some "dll" right in "C:\oracle\product\10.2.0\client_1\bin;". But when "C:\oraclesoa\app\oracle\product\10.2.0\server\bin;" was put front , ODBC go directly this directory to look for "dll" actually is in the "C:\oracle\product\10.2.0\client_1\bin;", then error happen.