1 2 3 Previous Next 37 Replies Latest reply on Dec 12, 2006 3:14 PM by pcharan Go to original post
      • 30. Re: Change Database Homepage Port
        Dietmar Aust
        Hi Mike,
        I couldn't reproduce the issue with 1.3.x either -
        however didn't Robert say he was having issues with
        it?
        True. But later he described his configuration having the Oracle http server running on XP and XE running on the same physical machine in a vm environment running linux.
        Perhaps there was something else going on there. I am not familiar with VM configurations.

        Anyway, I had tested with a standalone Apache 1.3 and an Oracle http server from 10gR2 on the same machine and on different machines (http server and XE) without problems.
        Or Apache 2 chokes on the responses for XE, and
        retries resulting in poor performance?
        I agree, perhaps Apache tries first with http 1.1 and then retries again using http 1.0. Perhaps this is the issue.

        Greetinx,
        ~Dietmar.
        • 31. Re: Change Database Homepage Port
          MarceloF.Ochoa
          Mike:
          If you use Firefox on linux and set using about:config screen:
          network.http.version 1.1
          Some images into HTMLDB administration pages are broken, so definitely there are problems using HTTP 1.1 and the XDB listener bundle on Oracle XE.
          Best regards, Marcelo.
          • 32. Re: Change Database Homepage Port
            466340
            Thanks Marcelo, that's interesting.

            Dietmar - I'm curious - did you try Apache 2 in a proxy pass config with the 10gR2 XDB listener of SE or EE of oracle. Given they share the same code base, maybe this issue exists with them also?

            Mike
            • 33. Re: Change Database Homepage Port
              Dietmar Aust
              Hi Mike,

              no, I only tested with Apache2 as a proxy to XE. But I am pretty confident they share the same "features" :).

              ~Dietmar.
              • 34. Re: Change Database Homepage Port
                Rpang-Oracle
                Mike:
                If you use Firefox on linux and set using
                ng about:config screen:
                network.http.version 1.1
                Some images into HTMLDB administration pages are
                re broken, so definitely there are problems using
                HTTP 1.1 and the XDB listener bundle on Oracle XE.
                Best regards, Marcelo.
                Please see thread Different behaviour: IE 6.0 vs. Firefox 1.07

                Thanks.
                • 35. Re: Change Database Homepage Port
                  466340
                  Mike:
                  If you use Firefox on linux and set using
                  ng about:config screen:
                  network.http.version 1.1
                  Some images into HTMLDB administration pages are
                  re broken, so definitely there are problems using
                  HTTP 1.1 and the XDB listener bundle on Oracle XE.
                  Best regards, Marcelo.
                  Please see thread
                  Excel output truncated (255 chars only) - Workaround?
                  39002.

                  Thanks.
                  Any chance you could let us see the text of bug 4705633? I'm wondering whether its associated to this Apache 2 issue...

                  Mike
                  • 36. Re: Change Database Homepage Port
                    MarceloF.Ochoa
                    Hi Robert:
                    Using HTTP/1.0 on firefox and HTTP pipeline enabled works fine, I think because network pipeline is a functionality of HTTP 1.1 specification.
                    So, network.http.version=1.0 or network.http.pipeline=false solves the workaround with Firefox in linux/windows.
                    Best regards, Marcelo.
                    • 37. Re: Change Database Homepage Port
                      pcharan
                      Hello Everyone,
                      I have similar issue, we have apache2.2 running on 8080 and installed XE, works very well with less speed, performence is really slow when i access this application from outside, but if i access the application on the server it is really fast, i applied this configuration in my apache

                      ProxyRequests Off

                      SetEnv force-proxy-request-1.0 1
                      SetEnv proxy-nokeepalive 1

                      ProxyPass /apex http://127.0.0.1:8080/apex
                      ProxyPassReverse /apex http://127.0.0.1:8080/apex
                      ProxyPass /i http://127.0.0.1:8080/i
                      ProxyPassReverse /i http://127.0.0.1:8080/i
                      ProxyPass /sys http://127.0.0.1:8080/sys
                      ProxyPassReverse /sys http://127.0.0.1:8080/sys

                      Please suggest me some solution.
                      Thanks
                      Anil
                      1 2 3 Previous Next