9 Replies Latest reply on Jan 21, 2009 4:08 PM by 681044

    Oracle 1053 error timely fasion

      I finished install oracle 8i DB in Windows XP and set new password for OMS. i can access the OMS i found out that i can not start The service,It shows with error 1053 (timely fasion), i made services manually ,even though its not Responding what else should do for this? plz help
        • 1. Re: Oracle 1053 error timely fasion

          you should parse OEM logs in order to know what prevents your OMS from starting. It can be multiple things from misconfiguration of network layer and credentials to <insert random problem here>.

          Look for the logfiles!

          • 2. Re: Oracle 1053 error timely fasion
            OK. Here's the solution !!!

            Disclaimer: This is highly UN-professional but it would help you to make a back up of your data before doing what Oracle/MS professionals tell you to do.

            (You must follow this procedure step by step.)

            Step 1: Open the services window and start the TNS listener ... if you have the OracleService(NAME) error 1053 problem, then I assume the TNS at least starts without problems.

            Step 2: Once the TNS is started, open the Task Manager / Processes tab.

            Step 3: Start the OracleService(NAME) from the Services window. Read this carefully before starting it: in the Processes tab at your Task Manager, two new process will appear: ORACLE.EXE and ORADIM.EXE. Usually when people have the 1053 error problem, the ORACLE.EXE occupies some 7,444 KB of memory space and stacks there with no progress. YOU MUST KILL THE ORADIM.EXE PROCESS ONCE IT APPEARS AT THE PROCESS TAB OF THE TASK MANAGER. Click it with your right-mouse-button and select End Process option.

            Step 4: Go back to your Services window and you will see that OracleService(NAME) is marked as started, but it is not REALLY started. However, the window of opportunity for your OracleService to be REALLY started has been already opened.

            Step 5: Launch your DBA Studio in a stand alone mode. It will list all of the databases that could be mounted to your system if started. Try to log to your preferred database by logging your self with the INTERNAL username/password.

            Step 6: Go to your preferred database, expand its tree, go to Instance tree, expand it, go to Database with your right-mouse-button click and select Startup.

            Then you must start biting your fingernails and pray it starts with no problems.

            If it says successfully started database, then PLEASE copy/paste this procedure at every forum where you posted your question and help other Oracle sufferers. This is by all means the best database created on earth and it must not be left unused because of the 1053 error.

            Well, have a nice day. My suggestion is that you do a backup instantly when you start your database and then seek a professional help, for this procedure is absolutely not professional, though the database works perfectly correct.

            Best regards, HF
            • 3. Re: Oracle 1053 error timely fasion

              Today I had same problem on my Oracle9i server on windows. I followed u r steps then I succeded. But I could't see ORADIM.EXE in the task manager.
              My steps was;
              1. started windows oracle services called OracleService<SID>
              2. in command prompt set oracle sid
              3. connect "/as sysdba"
              4. shutdown immediate
              5. startup open
              6. then i saw the oracleservice<SID> was started.

              Thanks a lot. --Karunai Mohame                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                           
              • 4. Re: Oracle 1053 error timely fasion
                as mentioned in the steps above:

                1. OracleService<SID> is not starting from controlpanel->services.
                2. How to connect as"/as sysdba" because when I type sqlplus/nolog in command prompt I get error " The procedure entry point LpxOraStreamParse could not be located in dynamic link linrary oraxml10.dll"
                3. So I am not able to shutdown or startup.

                This makes me stuck with this problem with no progress. Any help please....

                • 5. Re: Oracle 1053 error timely fasion
                  Hi ,

                  With reference to the previous message, I got this Oracle 1053 error where I could not log into sqlplus as sysdba or I can start the TNS listener to solver the issue as per the instruction given by other 2 users.

                  By detailed study, about the origin of the problem, I tried to install Oracle Designer on the same Oracle Home as the Oracle Database. This trigerred all the errors. I had nearly 3 dll files that was corrupt. I replaced the following dll files in the $oracle_home/bin directory :

                  oraxml10.dll, orahasgen10.dll and oraldap10clnt.dll

                  This sorted the problem and OracleService<sid> from the controlpanel->services started working.

                  This also caused me various other errors such as ORA-12560 and ora-12514. Everything was resolved by replacing the three corrupt files. Hope this saves some time for any one else who gets into this trouble

                  Good luck.
                  • 6. Re: Oracle 1053 error timely fasion

                    But ma'm from where i got these all .dll to replace (original one). Plz tell as i am novice in this field.

                    • 7. Re: Oracle 1053 error timely fasion
                      Hello HF thanks for ur help


                      Message was edited by:
                      • 8. Re: Oracle 1053 error timely fasion
                        Yes i have had similar problems with oracle....first i installed oracle 9i and it worked on the first day and when i restarted the computer it would either say "TNS Protocol Adapter Error" or it would say " Oracle not found".. To solve it ..what i did was i went into control panel->Administrative Tools-> Services.... In services
                        i checked what are the OracleService<name> that are running...if there are two or more i disabled everything except one... whichever u want to use...and the one remaining i changed its startup property to Manual... and after restarting the computer i just had to go to services and start the oracleservice<name> manually...and then logging into oracle was easy... if it still did not work..i opened task manager and end the oradim.exe and oracle.exe tasks and then go to services and start the oracleservice<name> manually ..

                        PS : the oracleservice<name> ...here the name is something given by you when the oracle is installed...
                        • 9. Re: Oracle 1053 error timely fasion. HELP!!!

                          I have a terrible problem. In the morning I checked my computer from viruses and spyware and it changed some keys in the registry.
                          The Oracle Listener and the OracleService stoped to run. I checked the registry and saw that the ImagePath key has disappeard!
                          I added it manually. The TNSListener started to work, but the Oracle Service gives me the 1053 error.
                          Maybe I didn't enter the right file to the ImagePath property. Is this "oracle.exe"?
                          I tried to do what you wrote here, but I get the error in a second so I can't kill the ORADIM. I even don't see it.

                          What can I do Now?

                          Can I reinstall The service without destroy the db itself?