1 2 Previous Next 22 Replies Latest reply on Mar 15, 2007 6:23 PM by 482477 Go to original post
      • 15. Re: Can't access MS ACCESS
        I've also noticed the same thing. I don't have a solution but I have noticed the following which might give a clue to the problem.
        After connecting to the MS Access database file, if one right-clicks the connection and selects the Properties menu item, then clicks on the Test button, the following Status message shows up in the lower left corner of the pop-up window: "Status: Failure -java.lang.NullPointerException".
        I hope someone can figure this out. Otherwise, this nice access to Access feature is not particularly useful.
        • 16. Re: Can't access MS ACCESS
          Barry Mcgillin-Oracle

          The reason for this is the the jdbc/ odbc bridge has very little access in an mdb. For us to navigate the access db, we need to be able to read the system tables and construct the relevant nodes.
          • 17. Re: Can't access MS ACCESS
            The solution is the new release of SQL Developer from February 27th.
            Now it works perfect
            • 18. Re: Can't access MS ACCESS
              Now it works perfect
              Yes, it seems only version 25.14 had had the problem

              • 19. Re: Can't access MS ACCESS
                I just downloaded and installed SQL Developer yesterday (March 13). When I started this morning it asked if I wanted to install some updates, some of which were for MS Access, so I did. I then tried to connect to an Access database. I have the same Failure-java.lang.NullPointerException error that you all said was fixed. Am I doing something wrong.
                • 20. Re: Can't access MS ACCESS
                  all said was fixed. Am I doing something wrong.
                  I dunno what are you doing? The updates were for the new migration workbench plug in and you problably didn't need them.
                  • 21. Re: Can't access MS ACCESS
                    I have rebooted my computer and restarted the programs and it works correctly now. I have no idea why I was getting the error before.
                    • 22. Re: Can't access MS ACCESS 2007 [solved]
                      For what it's worth, I just created an Access 2002-2003 database in Access 2007 and had similar problems connecting to it via SQL Developer. The solution appears to be similar - you need to grant read access to the MSysObjects table.

                      But in Access 2007, you first need to be able to see this table:

                      1. Click the office button at the top left and select "Access Options"
                      2. Select the "Current Database" tab
                      3. Under "Navigation", click the "Navigation Options" button
                      4. Ensure that "Show Hidden Objects" and "Show System Objects" are checked and click ok.
                      5. Now, when you select "Database Tools - Users and Permissions" on the ribbon, you'll be able to grant/revoke against the system objects

                      1 2 Previous Next