5 Replies Latest reply: Mar 3, 2008 8:25 PM by 586655 RSS

    Ruby-OCI8 with Oracle XE

    472559
      I've installed Oracle XE on Linux Suse..all works fine

      Then i wanted to install ruby-oci8 :
      Trying the command ruby setup.rb config gives me an error :
      I get the error :
      error messages:
      Cannot get proper libs.

      And more messages :
      /ruby-oci8-1.0.0-rc2/ext/oci8/oraconf.rb:649:in `get_libs': RuntimeError (RuntimeError)
      from /home/lbo/Desktop/ruby-oci8-1.0.0-rc2/ext/oci8/oraconf.rb:422:in `initialize'
      from /home/lbo/Desktop/ruby-oci8-1.0.0-rc2/ext/oci8/oraconf.rb:118:in `new'
      from /home/lbo/Desktop/ruby-oci8-1.0.0-rc2/ext/oci8/oraconf.rb:118:in `get'
      from /home/lbo/Desktop/ruby-oci8-1.0.0-rc2/ext/oci8/extconf.rb:6
      'system /usr/bin/ruby /home/lbo/Desktop/ruby-oci8-1.0.0-rc2/ext/oci8/extconf.rb ' failed
      Try 'ruby setup.rb --help' for detailed usage.
      make: *** [config.save] Erreur 1

      Anybody encountered this problem?

      Laurent

      Message was edited by:
      laurent.bois