5 Replies Latest reply: Jul 2, 2007 6:22 PM by 10259 RSS

    Web Cache Load Balancer

    willmehigan
      Hi,

      I have installed Oracle Application Server 10.1.2.0.2 Infrastructure and BI and Forms Midtier on 2 Windows2003 Server boxes.

      I want to use the Web Cache on one of these servers to Load Balance Forms requests to the two servers. I have been unable to get this working.

      I don't have a great knowledge of WebCache and have been unable to implement any of the notes I found on metalink.

      Any help would be greatly appreciated.

      Kindest regards,

      Will
        • 1. Re: Web Cache Load Balancer
          516174
          Hi, Am not sure about what notes on metalink are you referring to. Did you try using Web Cache Administrator's Guide? That's a pretty comprehensive neat guide with step-by-step instructions. Also, is there any particular problem you are facing?

          Hope this helps.

          Regards,
          Priyanka GES
          • 2. Re: Web Cache Load Balancer
            willmehigan
            Hi,

            Thanks for the response. I've followed the WebCache Admin guide plus note#'s 229900.1 and 268830.1.

            I have the Load Balance Cluster setup. I have configured two origin servers to my /forms/ site in my web cache cluster. When I try to run the forms URL however, I am getting an frm-9210: There was a failure......

            If I remove one of the origin servers from the site-to-server mapping the URL works fine - this however defies the point to load balancing 2 servers!

            I think it is down to my session binding settings but I have followed the metalink notes above and am still having the issue. I have an SR logged but nothing is happening there as yet !

            Any assistance would be very welcome.

            Thanks in advance,

            Will
            • 3. Re: Web Cache Load Balancer
              516174
              Hi, Did you try looking at Web Cache log file at <Oracle home>/webcache/logs dir? Also, what have your configured for the servers' capacity in the site-to-server mapping? Try removing your mapping & doing it again. What happens if one of the servers is down?

              Hope this helps.
              Regards,
              Priyanka GES
              • 4. Re: Web Cache Load Balancer
                10259
                Will,

                We are having the exact same problem! Our only difference is that we connecting to IIS on our origin servers... I have an active SR working, so if I find out anything I'll let you know.

                They had me install the 10.1.2.2 patch, but it hasn't made a difference yet... you have to install the database 10.1.0.5 patch first, then the AS patch.

                I'll keep you up to date
                • 5. Re: Web Cache Load Balancer
                  10259
                  Here it is...

                  You need to apply the patch #6155034 (for windows 32-bit platform) to get WebCache working for multiple origin servers. It is a brand new patch and works perfectly for us.

                  Hope this helps!