This discussion is archived
2 Replies Latest reply: Jul 4, 2007 6:11 AM by Marcelinho RSS

Output not getting relected in table

568547 Newbie
Currently Being Moderated
Hi,

I am using the stream dispatcher, and able to execute the sql procedure and also able to create the rule but could not able to received the data....

I have written the sql procedure as
CREATE TABLE rfid(tagid varchar2(128));
CREATE OR REPLACE PROCEDURE event_process(ev IN EDGE.EDG_EVENT) IS
BEGIN
     INSERT INTO rfid values(ev.id);
     COMMIT;
END event_process;


/
able to create the rule.... but not getting any data on the table...

Kindly let me know if you have any idea on the same....

In my Database i have received a error saying
STREAMS Warning: received error ORA-26663 while dropping apply EDG_APPLY for the queue "EDGE"."EDG_EVENT_Q". Please run dbms_apply_adm.drop_apply manually.

Thanks and regards
Nasim
  • 1. Re: Output not getting relected in table
    Marcelinho Newbie
    Currently Being Moderated
    Looks like a misconfiguration in your streams setup. Maybe you should try to drop the edge schema and recreate it manually:

    cd C:\oracle\AS10131\j2ee\home\applications\edge\edge\sql

    sqlplus system/…
    @create_edg_sda_user.sql

    sqlplus edge/…
    @edg_sda_with_edgeuser.sql

    sqlplus sys/… as sysdba
    @grant_edg_user.sql

    sqlplus edge/…
    @edg_create_streams.sql
  • 2. Re: Output not getting relected in table
    Marcelinho Newbie
    Currently Being Moderated
    Looks like a knot in your streams/queue setup. Maybe you should try to drop the edge schema and recreate it manually:

    cd C:\oracle\AS10131\j2ee\home\applications\edge\edge\sql

    sqlplus system/…
    @create_edg_sda_user.sql

    sqlplus edge/…
    @edg_sda_with_edgeuser.sql

    sqlplus sys/… as sysdba
    @grant_edg_user.sql

    sqlplus edge/…
    @edg_create_streams.sql