11 Replies Latest reply: Aug 11, 2009 11:14 PM by Herbert van den Bergh-Oracle RSS

    Install 11g on Unbreakable Linux 5 failing

    587185
      I have downoaded unbreakable linux 5 (x86 32). I installed the os and followed the installation manual in the welcome pages. I am stuck installing the database.
      Others prerequisites are passed but the packages fails and if I ignore them I still cannot get the installation to complete.

      INFO: Checking Packages
           This is a prerequisite condition to test whether the packages required for installing the product are available on the system.
      INFO: Checking for make-3.81; found make-1:3.81-1.1-i386.     Passed
      Checking for binutils-2.17.50.0.6; found binutils-2.17.50.0.6-2.el5-i386.     Passed
      Checking for gcc-4.1.1; Not found.     Failed <<<<
      Checking for libaio-0.3.106; found libaio-0.3.106-3.2-i386.     Passed
      Checking for libaio-devel-0.3.106; Not found.     Failed <<<<
      Checking for libstdc++-4.1.1; found libstdc++-4.1.1-52.el5-i386.     Passed
      Checking for elfutils-libelf-devel-0.125; Not found.     Failed <<<<
      Checking for sysstat-7.0.0; Not found.     Failed <<<<
      Checking for compat-libstdc++-33-3.2.3; Not found.     Failed <<<<
      Checking for libgcc-4.1.1; found libgcc-4.1.1-52.el5-i386.     Passed
      Checking for libstdc++-devel-4.1.1; Not found.     Failed <<<<
      Checking for unixODBC-2.2.11; Not found.     Failed <<<<
      Checking for unixODBC-devel-2.2.11; Not found.     Failed <<<<
      Check complete. The overall result of this check is: Failed <<<<

      Anyone do this successfully? Any suggestions? I am just testing so I don't have permission to get patches or updates.

      Thanks
        • 1. Re: Install 11g on Unbreakable Linux 5 failing
          504435
          Check and see if any of those packages are installed with:

          rpm -qa | grep <package name>
          • 2. Re: Install 11g on Unbreakable Linux 5 failing
            587185
            libgcc-4.1.1-52.el5
            libaio-0.3.106-3.2
            elfutils-libelf-0.125-3.el5
            sysstat -- not found
            libgcc-4.1.1-52.el5
            libstdc++-4.1.1-52.el5
            unixODBC -- not found

            Seems some are too new. Not sure I need ODBC, but sysstat??
            • 3. Re: Install 11g on Unbreakable Linux 5 failing
              Steeve
              Here is what i had to do after installing OEL5 for the package requirement.

              1.     Install the following “rpm” from the EL5 cd#2
              rpm -Uvh compat-libstdc++-33*
              rpm -ivh elfutils-libelf-devel-0.125-3.el5.i386.rpm elfutils-libelf-devel-static-0.125-3.el5.i386.rpm

              rpm -ivh glibc-devel-2.5-12.i386.rpm glibc-headers-2.5-12.i386.rpm gcc-4.1.1-52.el5.i386.rpm libgomp-4.1.1-52.el5.i386.rpm

              rpm -ivh gcc-c++-4.* libstdc++-devel-4.1.1-52.el5.i386.rpm
              rpm -Uvh libaio-devel-0.*
              rpm -Uvh unixODBC-2.*
              rpm -Uvh unixODBC-devel-2.*

              2.     Install the following “rpm” from the EL5 cd#3
              rpm -Uvh sysstat-7.*

              Message was edited by:
              Steeve
              • 4. Re: Install 11g on Unbreakable Linux 5 failing
                587185
                That was it, Thanks!
                • 5. Re: Install 11g on Unbreakable Linux 5 failing
                  Ivan Kartik
                  I have been already posted my installation paper for 11g (valid for EL and RHEL).
                  Maybe it can help you it next tasks: http://ivan.kartik.sk/oracle/install_ora11gR1_elinux.html
                  • 6. Re: Install 11g on Unbreakable Linux 5 failing
                    202498
                    O.K. I had the EL5 (cd2) in the cd rom..and I logged in as root..
                    and this is what I get:

                    [root@localhost Enterprise Linux cd 2 20070613]# rpm -Uvh compat-libstdc++-33*
                    error: File not found by glob: compat-libstdc++-33*
                    • 7. Re: Install 11g on Unbreakable Linux 5 failing
                      511303
                      Why are you guys so complicating something that is so trivial and simple? The 11g installation guide for Linux states clearly that (for OEL-5) the following packages must be installed:
                      binutils-2.17.50.0.6-2.el5
                      compat-libstdc++-33-3.2.3-61
                      elfutils-libelf-0.125-3.el5
                      elfutils-libelf-devel-0.125
                      glibc-2.5-12
                      glibc-common-2.5-12
                      glibc-devel-2.5-12
                      gcc-4.1.1-52
                      gcc-c++-4.1.1-52
                      libaio-0.3.106
                      libaio-devel-0.3.106
                      libgcc-4.1.1-52
                      libstdc++-4.1.1
                      libstdc++-devel-4.1.1-52.e15
                      make-3.81-1.1
                      sysstat-7.0.0
                      unixODBC-2.2.11
                      unixODBC-devel-2.2.11
                      All these packages are on OEL-5 distribution media pack (CDs) and you can install them at any time. The simplest way to do so is to choose the packages during main installation. Never accept the default installation image on the installer screen. Instead, choose the packages yourself.

                      N.J.
                      • 8. Re: Install 11g on Unbreakable Linux 5 failing
                        202498
                        One would imagine that all these packages would be installed "by default" from a vendor who owns the operating system now and is certifying their latest product on it (11G)...but no..we have to do all this love and care afterwords..
                        But Thanks NJ for pointing those packages out..I am sure it's all there in the documentation...
                        I am just not as up-to-speed on linux/RPM installs..
                        • 9. Re: Install 11g on Unbreakable Linux 5 failing
                          511303
                          > One would imagine that all these packages would be
                          installed "by default" from a vendor who owns the
                          operating system now and is certifying their latest
                          product on it (11G)...but no..

                          Absolutely right. The default installation should be with all those required packages. It's one of the reasons why OEL exists at all. Obviously Oracle's Linux Product Management folks don't care about it. So, we must take care. Fortunately, the problem is trivial anyway.

                          N.J.
                          • 10. Re: Install 11g on Unbreakable Linux 5 failing
                            dan.williams@oracle.com
                            geez.. now I know why the consultants and DBAs make all that money! Heck if it was as easy as choosing all those packages with an option to install them by letting the installer know it is for 11g, where would the DBAs and all those consultants go??

                            It's riduculous to be sifting through all those rpms and trying to install them, only to find that there are more dependant objects that need to be installed first and go around hunting for them in all the 5 CDs?? what rubbish!
                            • 11. Re: Install 11g on Unbreakable Linux 5 failing
                              Herbert van den Bergh-Oracle
                              Do you mean something as simple as:

                              up2date oracle-validated