This discussion is archived
8 Replies Latest reply: Sep 3, 2007 5:38 AM by 3004 RSS

Attributes problem

3004 Newbie
Currently Being Moderated
<p>Hi,</p><p> </p><p>This is an emergency, could someone please offer theirexpertise.</p><p> </p><p>I'm working on a company merger and am working on the essbase new chart of accounts. I've created my essbase cube and people are testing but recently people wanted to be able to test the 2 companies separately so i set up attributes to the company codes so they couldreport on any one of the 3 companies.   In the originaloutline before the attributes, one of the companies was notincluded in the total roll up so I had to include this to theattributes to match.</p><p> </p><p>i.e Company A andB roll up to the total amount in Accounts and Company C is reported on separately.</p><p>In attributes Company A and B should technically equal the same as the balance without using the attribute function.</p><p> </p><p>This is not happening.   What i'm getting is a different balance is ifi  retrieve without   any attributes I get 50,If i type the attribute dimension name 'split' I get 60  andif i drill to each attribute I get 20 for each.  Now if idrill on Company B i can see a balance thats not there on initialretreival without the attributes, or even when i type split.  it's only there when i type the attribute name.</p><p> </p><p>This makes me believe there must be a way to roll up attributesbut i can't find it anywhere.....   Does anyone know anycalc scripts that may help?</p><p> </p><p> </p><p>Please help!</p><p> </p><p>Thanks in advance</p>
  • 1. Attributes problem
    3004 Newbie
    Currently Being Moderated
    What version of Essbase are you using ?<BR><BR>If it is below 6.5.6 then you may well continue to experience problems with attribute calculations, as these did not work 100% until then.<BR><BR>If you are on a version higher than this, then my question si swhy are you bothering with attributes ?<BR><BR>Why don't you use the + / - operators in the company dimension or use a new hierarchy with shared members to acheive the required result - it's much easier.
  • 2. Attributes problem
    3004 Newbie
    Currently Being Moderated
    <p>Hi, thanks for your reply.  </p><p>We are using essbase 7.1 so the answers to yourquestions....</p><p> </p><p>1) Why not use +/- on company?...  </p><p> I already am using plus company codes for A & B and~ignore Company C codes.  This reflects well in the reportingas Company C is reported separately anyway.</p><p> </p><p>2) Why don't we create a new hierarchy with shared members andwhy bother with attributes?  See this is where I'm confused asI went to the essbase bootcamp and basically got told that this iswhere attributes work best and this is the kind of situation theyare created for.    Using shared members here wouldmean creating a very large duplicated hierarchy and this wouldconfuse the essbase users more than help them.</p><p> </p><p>I'm not sure if what i'm saying makes sense so if anyone elseagrees that shared members will work better here then please let meknow and I will give it a go and see hwo this works.   Ifyou have any other suggestions please don't hesitate.#</p><p> </p><p> </p><p>Thanks</p><p> </p>
  • 3. Attributes problem
    3004 Newbie
    Currently Being Moderated
    OK.<BR><BR>Questions:<BR><BR>Are the Comapnies in a separate dimension ?<BR><BR>If yes - how many companies in the dimension ?<BR><BR><BR>Also, if we are only talking about three companies, then using shared members is only going to have a negligible effect.<BR><BR>If you post your e-mail, I can contact you directly to go through the options.
  • 4. Attributes problem
    3004 Newbie
    Currently Being Moderated
    I don't know if this applies to your situation, or if it may work differently in more recent versions of Essbase, but I found a couple of years ago that I did not get correct results using attribute dimensions in combination with dynamic two-pass calc measures that used consolidation (rollup) settings from child members rather than member formulas to determine the value. The results were correct when I changed the measures to use formulas. (However the query performance was degraded.)
  • 5. Attributes problem
    3004 Newbie
    Currently Being Moderated
    there's nothing wrong with using the attributes. double check your sparse dimension members and make sure that you are tagging the correct members with the correct attributes. Export level1 data and reload and then re-calc-all; sometimes, toggling with the outline and data-loading may cause lev1 members loaded with their children reset to #missing. if the attributes become a continuous error for you, stick with the consolidation operators. company a,b, and c should not be in separate dimensions, perhaps try something like this...:company one(~) /* display this to represent value for company a and b */ company_a(+) company_b(+) two(~) /* display this value to represent company c */ company_c(+)
  • 6. Attributes problem
    3004 Newbie
    Currently Being Moderated
    <p>Thanks for all your advice here.   The problemwas:</p><p> </p><p>There is a group of companies in one roll up that do their ownreporting and they were excluded initally with ~</p><p>When i set the attributes these companies were tagged with onecompany attribute hence this will cause  a problem when youreport on these different attributes.</p><p> </p><p>Thanks for all your help everyone.</p><p> </p><p>Dreamscapeuk</p>
  • 7. Attributes problem
    3004 Newbie
    Currently Being Moderated
    hi everyone<BR>i have created an outline using attributes and i have created a rule file and data has been loaded succesfully without any errors.can anyone help me how to view these attribute columns in the excel spreadsheet.
  • 8. Attributes problem
    3004 Newbie
    Currently Being Moderated
    hi everyone<BR>i have created an outline using attributes and i have created a rule file and data has been loaded succesfully without any errors.can anyone help me how to view these attribute columns in the excel spreadsheet.