3 Replies Latest reply on Dec 15, 2008 12:44 PM by 595550

    [nQSError:37001] Could not connect to BI Server Instance

      Greetings All,

      Operating system: Window XP

      BI EE

      Following services running:

      Oracle BI Java Host
      Oracle BI Presentation Server
      Oracle BI Server.
      OC4J is running.

      I created a repository based on SH schema. Ran queries from Presentation service > Answers. All were working fine.

      Now I cannot connect to repository in on-line mode and cannot connect to Presentation Service.

      I can connect to repository in offline mode (start > All Programs > Oracle Business Intelligence > Administration). However, when I try to connect in online mode I get following error:
      [nQSError:37001] Could not connect to BI Server Instance.

      After getting this error when I check services I see that Oracle BI Services has stopped.

      I restart the service and try to connect in online mode and again I get the same error - [nQSError:37001]...... and see that Oracle BI Server service has stopped.

      (2) Check that the BI services are running and OC4J is running.
      I start the presentation services (start > All Programs > Oracle Business Intelligence > Presentation Services). I get the log on screen. I try to log on (e.g., as Administrator) I get following error:

      Odbc driver returned an error (SQLDriverConnectW).
      Error Details
      Error Codes: OPR4ONWY:U9IM8TAC
      State: HY000. Code: 10058. [NQODBC] [SQL_STATE: HY000] [nQSError: 10058] A general error has occurred. [nQSError: 12002] Socket communication error at call=recv: (Number=10038) An operation was attempted on something that is not a socket. (HY000)

      After getting this error I see that Oracle BI Service has stopped.

      I have not made any change to config file.

      Only change in my machine since the last time everything worked is I have upgraded Norton Internet Security 2007 to 2008 version. I checked the Program Control and all excecutable are "Allowed".

      Since this upgrade to Internet Security 2008 my 10g DB (em,isqlplus,sqlplus), Tools (e.g., Disco) and other non-Oracle tools are working .

      Any suggestion?

      Thanks in advance for your help.

      Message was edited by: