1 2 3 4 Previous Next 50 Replies Latest reply on Mar 7, 2008 7:42 PM by Madrid Go to original post
      • 45. Re: emctl dbconsole not starting
        Aman....
        Try reconfiguring the listener with netca.I am not sure but you are facing much more problems than what I have seen happening on one pc. Well no issues, if a problem is there, a solution is also there.
        Aman....
        • 46. Re: emctl dbconsole not starting
          620899
          Hi Mvanle,
          Thank you, I have delete the listener service , but when I am going to create it through NetCA, it gives following error...

          C:\>NetCA
          Oracle Net Services Configuration:
          Exception in thread "main" java.util.MissingResourceException: Can't find resour
          ce for bundle oracle.net.ca.mesg.NetCASR, key StandAloneNSNCreate
          at java.util.ResourceBundle.getObject(ResourceBundle.java:314)
          at java.util.ResourceBundle.getString(ResourceBundle.java:274)
          at oracle.net.ca.NetStrings.getString(NetStrings.java:70)
          at oracle.net.ca.CAPanelNetServiceNameStandalone.<init>(CAPanelNetServic
          eNameStandalone.java:30)
          at oracle.net.ca.NetCA.init(NetCA.java:621)
          at oracle.net.ca.NetCA.<init>(NetCA.java:265)
          at oracle.net.ca.NetCA.main(NetCA.java:165)

          So now there is no listener available.

          C:\>lsnrctl status

          LSNRCTL for 32-bit Windows: Version 10.1.0.2.0 - Production on 27-FEB-2008 10:15
          :02

          Copyright (c) 1991, 2004, Oracle. All rights reserved.

          Connecting to (ADDRESS=(PROTOCOL=tcp)(PORT=1521))
          TNS-12541: TNS:no listener
          TNS-12560: TNS:protocol adapter error
          TNS-00511: No listener
          32-bit Windows Error: 61: Unknown error

          Is there any alternative to create that? My DBCA also not working.

          Thanks

          Suman
          • 47. Re: emctl dbconsole not starting
            mvanle
            Wow. Can't even create a listener.

            Your Oracle configuration is seriously messed up :)

            Try providing us with your Oracle registry settings:

                C:\>regedit /e oracle_env.txt "HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE"

            and maybe we can check for any obvious problems in your paths.

            Nb. regedit outputs unicode so you need an UTF8 editor (eg. notepad) to view the text file.

            Apart from that, it's at times like these that you backup %ORACLE_BASE%\oradata, reinstall Oracle software and recreate your database manually ... or pay for MetaLink :)

            Get a system backup, (for academic reasons) so that when you're an Oracle Certified Master you can finish this fine mess =P
            • 48. Re: emctl dbconsole not starting
              620899
              Hi Mvanle,
              Thanks, So many things I have learned from all of you due to this problem..

              Here is my registry.
              -------------------------------
              Windows Registry Editor Version 5.00

              [HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE]
              "inst_loc"="C:\\Program Files\\Oracle\\Inventory"
              "ORA_CRS_HOME"="C:\\oracle\\product\\10.1.0\\Db_1"

              [HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\ALL_HOMES]
              "HOME_COUNTER"="1"
              "DEFAULT_HOME"="DEFAULT_HOME"
              "LAST_HOME"="0"

              [HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\ALL_HOMES\ID0]
              "NAME"="OraDb10g_home1"
              "PATH"="C:\\oracle\\product\\10.1.0\\Db_1"
              "NLS_LANG"="NA"

              [HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\HOME0]
              "ORACLE_GROUP_NAME"="Oracle - OraDb10g_home1"
              "ORACLE_HOME_NAME"="OraDb10g_home1"
              "ORACLE_HOME"="C:\\oracle\\product\\10.1.0\\Db_1"
              "NLS_LANG"="AMERICAN_AMERICA.WE8ISO8859P1"

              [HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\KEY_OraDb10g_home1]
              "ORACLE_HOME"="C:\\oracle\\product\\10.1.0\\Db_1"
              "ORACLE_HOME_NAME"="OraDb10g_home1"
              "ORACLE_GROUP_NAME"="Oracle - OraDb10g_home1"
              "ORACLE_BUNDLE_NAME"="Enterprise"
              "NLS_LANG"="AMERICAN_AMERICA.WE8MSWIN1252"
              "OLEDB"="C:\\oracle\\product\\10.1.0\\Db_1\\oledb\\mesg"
              "ORACLE_SID"="ORCL"
              "OO4O"="C:\\oracle\\product\\10.1.0\\Db_1\\oo4o\\mesg"
              "SQLPATH"="C:\\oracle\\product\\10.1.0\\Db_1\\dbs"
              "ORACLE_HOME_KEY"="SOFTWARE\\ORACLE\\KEY_OraDb10g_home1"
              "ORACLE_BASE"="C:\\oracle\\product\\10.1.0"
              "MSHELP_TOOLS"="C:\\oracle\\product\\10.1.0\\Db_1\\MSHELP"
              "RDBMS_CONTROL"="C:\\oracle\\product\\10.1.0\\Db_1\\DATABASE"
              "RDBMS_ARCHIVE"="C:\\oracle\\product\\10.1.0\\Db_1\\DATABASE\\ARCHIVE"
              "ORA_ORCL_AUTOSTART"=hex(2):46,00,41,00,4c,00,53,00,45,00,00,00
              "ORA_ORCL_SHUTDOWN"=hex(2):54,00,52,00,55,00,45,00,00,00
              "ORA_ORCL_SHUTDOWNTYPE"=hex(2):69,00,6d,00,6d,00,65,00,64,00,69,00,61,00,74,00,\
              65,00,00,00
              "ORA_ORCL_SHUTDOWN_TIMEOUT"=hex(2):39,00,30,00,00,00
              "ORA_OCP10G_AUTOSTART"=hex(2):46,00,41,00,4c,00,53,00,45,00,00,00
              "ORA_OCP10G_SHUTDOWN"=hex(2):54,00,52,00,55,00,45,00,00,00
              "ORA_OCP10G_SHUTDOWNTYPE"=hex(2):69,00,6d,00,6d,00,65,00,64,00,69,00,61,00,74,\
              00,65,00,00,00
              "ORA_OCP10G_SHUTDOWN_TIMEOUT"=hex(2):39,00,30,00,00,00

              [HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\KEY_OraDb10g_home1\ODP.NET]
              "TraceFileName"="C:\\ODPNET.trc"
              "TraceLevel"="0"
              "TraceOption"="0"

              [HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\KEY_OraDb10g_home1\OLEDB]
              "CacheType"="Memory"
              "ChunkSize"="100"
              "DistribTX"="1"
              "FetchSize"="100"
              "OSAuthent"="0"
              "PLSQLRset"="0"
              "PwdChgDlg"="1"
              "SchRstLng"="10000"
              "UserDefFn"="0"
              "DisableRetClause"="1"
              "VCharNull"="1"
              "TraceCategory"="0"
              "TraceFileName"="c:\\OraOLEDB.trc"
              "TraceLevel"="0"
              "TraceOption"="0"
              "SPPrmDefVal"="0"

              [HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\KEY_OraDb10g_home1\OO4O]
              "CacheBlocks"="20"
              "FetchLimit"="100"
              "FetchSize"="4096"
              "HelpFile"="C:\\oracle\\product\\10.1.0\\Db_1\\oo4o\\doc\\oracleo.hlp"
              "PerBlock"="16"
              "SliceSize"="256"
              "TempFileDirectory"="c:\\temp"
              "OO4O_HOME"="C:\\oracle\\product\\10.1.0\\Db_1\\oo4o"

              [HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\Ocr]
              "ocrconfig_loc"="C:\\oracle\\product\\10.1.0\\Db_1\\cdata\\localhost\\local.ocr"
              "Local_Only"="TRUE"

              [HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\SCR]

              [HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\SYSMAN]

              [HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\SYSMAN\OracleDBConsoleocp10g]
              "EMDROOT"="C:\\oracle\\product\\10.1.0\\Db_1"
              "ORACLE_HOME"="C:\\oracle\\product\\10.1.0\\Db_1"
              "EMSTATE"="C:\\oracle\\product\\10.1.0\\Db_1\\localhost_ocp10g"
              "CONSOLE_CFG"="dbconsole"
              "ORACLE_SID"="ocp10g"
              "TIMEOUT"="15"
              "TRACE_LEVEL"="16"

              [HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\SYSMAN\OracleDBConsoleorcl]
              "EMDROOT"="C:\\oracle\\product\\10.1.0\\Db_1"
              "ORACLE_HOME"="C:\\oracle\\product\\10.1.0\\Db_1"
              "EMSTATE"="C:\\oracle\\product\\10.1.0\\Db_1\\suman_orcl"
              "CONSOLE_CFG"="dbconsole"
              "ORACLE_SID"="orcl"
              "TIMEOUT"="15"
              "TRACE_LEVEL"="16"
              -------------------------------

              Regards
              Suman
              • 49. Re: emctl dbconsole not starting
                627301
                Hi,

                I'm working on Oracle RAC 10gR2 on two linux RHEL4 nodes dbu01 and dbu02, and I have a very similar problem.

                when I execute

                # su - oracle
                # emctl start dbconsole

                I get the error :

                OC4J Configuration issue. /u01/app/oracle/product/10.2.0/db_1/oc4j/j2ee/OC4J_DBConsole_dbu01_mysid not found.

                But when I searched in "/u01/app/oracle/product/10.1.0/db_1/oc4j/j2ee/", I found a folder named "OC4J_DBCONSOLE" that contains all config files. Why my folder was created without the <hostname>_<sid> suffix???

                Also when I go to the folder "/u01/app/oracle/product/10.2.0/db_1/", I guess I'm supposed to find a "<hostname>_<sid>" folder under which I could find the "sysman" folder. But I find the "sysman" folder directly under "/u01/app/oracle/product/10.2.0/db_1/"...

                Any advice? Do a need to drop my repository and start EM configuration from scratch? Would this affect my database that is running on production?

                Br.
                • 50. Re: emctl dbconsole not starting
                  Madrid
                  Please check your PATH environment variable, the error:

                  Message 1411 not found; product=NETWORK; facility=TNS

                  Message 1408 not found; product=NETWORK; facility=TNS


                  Without a regular oracle format error means oracle cannot properly find the error message, which happens when your environment variables are not properly set. The above error related to the configuration assistant invocation is also another indication of a missconfigured environment variable.


                  ~ Madrid
                  1 2 3 4 Previous Next