3 Replies Latest reply on Mar 12, 2009 12:32 PM by ra.

    Cannot execute runInstaller - no .Xauthority is created

      Hello --

      I am trying to install Oracle on one of the servers (running Solaris 5.10). When I try to execute runInstaller I get the following error:

      Could not execute auto check for display colors using command /usr/openwin/bin/xdpyinfo. Check if the DISPLAY variable is set Failed <<<<
      After doing lots of debugging, I realized that .Xauthority does not get created when I try to do the install. I am running Exceed locally on my machine, attempting to install Oracle on a remote server. I have followed Oracle documentation, where our admins set up the server accordingly. This is what I have checked so far:

      1. I log in as me and then in my .profile su - oracle
      2. X11 forwarding is enabled (I am using ssh)
      3. I tried to create .Xauthority from my mashine via the following:
      ssh2 -X username@myhost*
      4. I tried to create it manually by executing xauth:
      -bash-3.00$ xauth
      xauth:  creating new authority file /data/app/home/oracle/.Xauthority
      Using authority file /data/app/home/oracle/.Xauthority
      xauth> list
      xauth> info
      Authority file:       /data/app/home/oracle/.Xauthority
      File new:             yes
      File locked:          no
      Number of entries:    0
      Changes honored:      yes
      Changes made:         no
      Current input:        (stdin):2
      However, the file is not in /data/app/home/oracle. It says that it creates it, but it'not.

      4. I set DISPLAY variable to localhost:0.0 (also tried localhost:10.0)

      I have no idea why .Xauthority does not get created. Any ideas would be greatly appreciated. Thank you!