8 Replies Latest reply: Sep 19, 2008 10:59 AM by user522961 RSS

    Could not open registry. Registry name: mysystem

    user522961
      Hi,
      when loging to mysystem, after entring username/password I receive :
      Could not open registry. Registry name: MYSYTEM.

      Any idea ?

      Thank you.
        • 1. Re: Could not open registry. Registry name: mysystem
          Nicolas.Gasparotto
          What Peopletools version are you using ? Webserver ? OS ?
          Did you check the webserver/appserver log files ?

          Nicolas.
          • 2. Re: Could not open registry. Registry name: mysystem
            user522961
            Thank you Nicolas.
            Peopletools version 8.48.16. Webserver Weblogic 8.1 ,OS : Win 2003 Server. In logs :

            APPSRV_0919.LOG

            PS@w2k3PortalRegistry](2) CPrdm::LoadDefn failed with error code 3.
            PSAPPSRV.1160 (3) [09/19/08 01:52:25 PS@w2k3.PortalRegistry](2) PrdmGet failed with error code 3, portal name HR9AL

            and in PIA_servlets0.log.1 :

            SEVERE: PortalRegistry.open failed for Portal=MYSYSTEM because PortalRegistrySvc returnCode != 0
            Sep 19, 2008 1:16:16 AM psft.pt8.util.PIAContext log
            SEVERE:
            Could not open registry: MYSYSTEM
            • 3. Re: Could not open registry. Registry name: mysystem
              Nicolas.Gasparotto
              Please, run the following statement against your database :
              select MSGNODENAME,LOCALDEFAULTFLG,LOCALNODE,PORTAL_NAME from PSMSGNODEDEFN where LOCALDEFAULTFLG='Y';
              In most of case, the portal_name should be EMPLOYEE for the default local node.

              Nicolas.
              • 4. Re: Could not open registry. Registry name: mysystem
                user522961
                Thank you Nicolas :
                SQL> select MSGNODENAME,LOCALDEFAULTFLG,LOCALNODE,PORTAL_NAME from PSMSGNODEDEFN where LOCALDEFAULTFLG='Y';
                
                MSGNODENAME                    L  LOCALNODE PORTAL_NAME
                ------------------------------ - ---------- ------------------------------
                PSFT_HR                        Y          1 EMPLOYEE
                • 5. Re: Could not open registry. Registry name: mysystem
                  Nicolas.Gasparotto
                  Does HR9AL your portal name ?
                  And also, please check the start.html of your webserver, verify the url of the frame header, please post here the content.

                  Nicolas.
                  • 6. Re: Could not open registry. Registry name: mysystem
                    user522961
                    Thank you Nicolas.
                    Does HR9AL your portal name ? It is the name of my system (my peoplesoft environment and it's oracle DB).
                    What is frame header ?
                    Content of what ?
                    Here is the content of start.html in E:\PT8.48\webserv\peoplesoft\applications\peoplesoft\PORTAL\WEB-INF\psftdocs\HR9AL :
                    <html>
                    <!--* ******************************************************************
                    * ******************************************************************
                    *
                    *                          
                    *
                    *                                                                   
                    * ******************************************************************
                    *
                    ********************************************************************-->
                    
                    <LINK REL="SHORTCUT ICON" HREF="<%=psCtxPath%><%=psHome%>/favicon.ico">
                    <frameset rows="82,*" border="0" frameborder="0">
                    <frame name="header" SRC="<%=servletLoc%>PORTA/QE_LOCAL/s/WEBLIB_MENU.ISCRIPT3.FieldFormula.IScript_GetMenuHeader/" FRAMEBORDER="0" marginheight="0" scrolling="no" noresize>
                    <frame name="main" SRC="<%=servletLoc%>PORTAL/QE_LOCAL/s/WEBLIB_MENU.ISCRIPT3.FieldFormula.IScript_DrillDown/?Level=0" FRAMEBORDER="0" marginheight="0">
                    </frameset>
                    </html>
                    <!--
                    * ****************************************************************** 
                    * ORACLE CONFIDENTIAL.  For authorized use only.  Except for as      
                    * expressly authorized by Oracle, do not disclose, copy, reproduce,  
                    * distribute, or modify.                                             
                    * ****************************************************************** 
                    *                                                                    
                    -->
                    • 7. Re: Could not open registry. Registry name: mysystem
                      Nicolas.Gasparotto
                      What happens if you replace
                      <frame name="header" SRC="<%=servletLoc%>PORTA/QE_LOCAL...{code}
                      by
                      {code}<frame name="header" SRC="<%=servletLoc%>PORTAL/QE_LOCAL...
                      Stop all, purge cache, and restart all.

                      Nicolas.
                      • 8. Re: Could not open registry. Registry name: mysystem
                        user522961
                        Thank you Nicolas, I did the following :
                        Stop all, purge cache, and restart all.
                        And everything is OK now.
                        Regards.