This discussion is archived
1 2 Previous Next 16 Replies Latest reply: Oct 28, 2008 5:40 PM by 667566 Go to original post RSS
  • 15. Re: emca: Failed to allocate port(s) in the specified range...
    644335 Newbie
    Currently Being Moderated
    I changed the /etc/hosts line
    127.0.0.1     localhost.domain localhost
    to
    127.0.0.1          v204-101.wat.edu.pl v204-101
    and it did work
    but still I couldn't start lsnrctl and I look to file:
    /u01/app/oracle/product/10.2.0/db_1/network/admin/listener.ora
    LISTENER =
    (DESCRIPTION_LIST =
    (DESCRIPTION =
    (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1))
    (ADDRESS = (PROTOCOL = TCP)(HOST = v204-101.wat.edu.pl)(PORT = null))
    )
    )
    I changed the PORT parameter and its works
    Maybe if we would change HOST parameter to localhost.localdomain it would also works without changing file /etc/hosts, but I don't know if it is allowed to change this file because it is generated automatically
  • 16. Re: emca: Failed to allocate port(s) in the specified range...
    667566 Newbie
    Currently Being Moderated
    I'm having the same problem as the original post (I'm using 11g).

    What I don't understand is why this happens from a clean install and default database creation during the install. I've tried setting ORACLE_HOSTNAME but the listener.ora and tnsnames.ora still use NULL for the TCP port.

    Anyone, anyone, Bueler, anyone...
1 2 Previous Next