1 Reply Latest reply: Oct 30, 2008 2:57 AM by sxkumar RSS

    Anyone used the 32bit Oracle 11106_EE AMI and has it working?

      I've gotten a fresh AMI of the EE installation running and have a database created. My problem is I can't connect to any of the http ports. I've done the ec2-authorize commands to open the ports and can connect to the listsner port (1521), but the em port and apex port won't connect. Does anyone have any ideas where I could start looking to troubleshoot? It all looked so easy in the video :) I've tried stopping and restarting the dbconsole (emctl start dbconsole) and find an error in the emagent.log file "Startup of HTTP LISTENER failure". When I go into the database and try to open the apex listener I receive this:
      SQL> exec dbms_xdb.setlistenerlocalaccess(FALSE);
      BEGIN dbms_xdb.setlistenerlocalaccess(FALSE); END;

      ERROR at line 1:
      ORA-30952: illegal configuration of HTTP/HTTPS in xdbconfig.xml
      ORA-06512: at "XDB.DBMS_XDB", line 713
      ORA-06512: at "XDB.DBMS_XDB", line 885
      ORA-06512: at line 1

      Not quite sure what is going on with this. I'd appreciate it if someone could point me in the right direction.

        • 1. Re: Anyone used the 32bit Oracle 11106_EE AMI and has it working?
          If you have opened ports 1158 (for EM) and 8080 (for APEX), you should not be running into this problem.

          If this is still an issue, I suggest you fire up another EC2 instance with the same AMI and see if you can access the http port. If the database creation process completes successfully, the EM and APEX should be configured and http ports should be accessible. If not, there has to be an issue with your security groups (e.g. opened port) setting.