This discussion is archived
1 2 Previous Next 19 Replies Latest reply: Sep 13, 2013 10:03 AM by moksh RSS

Can't apply SWSE config profile

667711 Newbie
Currently Being Moderated
Hi i have some problem,
We use 4 phisical servers

1) Oracle database (Solaris 10)
2) Siebel gateway name server (Solaris 10)
3 )Siebel Application server (Win2003)
4) siebel -web server (based on Sun Java Web server; Solaris 10)

I have been configured and applyed all prevus service (such as Gateway; Enterp. server; Database )
I installed SWSE on Siebel web server.
After that i genarated logical profile on siebel Gateway name server and copy them on siebel web server.
when i applying configuration on SWSE he say me that "Execution Failed".
In log file i can see:


2021 2008-10-29 16:42:24 0000-00-00 00:00:00 +0300 00000000 001 003f 0001 09 sw_cfg_util 8285 14 /opt/SBA80/sweapp/log/sw_cfg_util.log
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:24 Executing step: ConfigMode
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:24 Executing step: MainTask
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:24 Executing step: MainTaskRemove
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:24 Executing step: SWSERoot
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:24 Executing step: AdminUser
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:24 Executing step: AdminPassword
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:24 Executing step: TRACELEVELDEFAULT
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:24 Executing step: DeployedLanguage
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:24 Executing step: SiebelRootUnix
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:24 Executing step: DoubleQuote
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:24 Executing step: GatewayAddress
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:24 Executing step: EnterpriseServer
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:24 Executing step: RequestComponent
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:24 Executing step: RequestServer
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:24 Executing step: DeleteVirDirs
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:26 (ossystem.cpp (96) err=255 sys=0) SBL-GEN-00255: Internal: Error during exec()
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:26 Step DeleteVirDirs: failed to run program cmd with cmdline /C del %%SiebelRoot%%%%OSDirSeparator%%bin%%OSDirSeparator%%novirdirs.bat
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:26 Executing step: CreateVirDirsBatLine1$$DeployedLanguage$$
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:26 Executing step: CreateNoVirDirsBatLine2$$DeployedLanguage$$
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:26 Executing step: CreateNoVirDirsBatLine2enu
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:26 Executing step: CreateNoVirDirsBatLine2deu
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:26 Executing step: CreateNoVirDirsBatLine2esn
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:26 Executing step: CreateNoVirDirsBatLine2ita
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:26 Executing step: CreateNoVirDirsBatLine2nld
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:26 Executing step: CreateNoVirDirsBatLine2ptb
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:26 Executing step: CreateNoVirDirsBatLine2ptg
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:26 Executing step: CreateNoVirDirsBatLine2fra
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:26 Executing step: CreateNoVirDirsBatLine2dan
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:26 Executing step: CreateNoVirDirsBatLine2fin
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:26 Executing step: CreateNoVirDirsBatLine2chs
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:26 Executing step: CreateNoVirDirsBatLine2cht
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:26 Executing step: CreateNoVirDirsBatLine2csy
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:26 Executing step: CreateNoVirDirsBatLine2heb
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:26 Executing step: CreateNoVirDirsBatLine2jpn
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:26 Executing step: CreateNoVirDirsBatLine2kor
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:26 Executing step: CreateNoVirDirsBatLine2sve
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:26 Executing step: CreateNoVirDirsBatLine2ara
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:26 Executing step: CreateNoVirDirsBatLine2tha
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:26 Executing step: RunEappsBat
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:26 (icutil.cpp (108) err=3604484 sys=0) SBL-ICF-00004: The input string was null or empty
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:28 (ossystem.cpp (96) err=255 sys=0) SBL-GEN-00255: Internal: Error during exec()
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:28 Step RunEappsBat: failed to run program %%SiebelRoot%%%%OSDirSeparator%%bin%%OSDirSeparator%%novirdirs with cmdline <NULL>
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:28 Executing step: VerifyDeleteSWSEPhysical
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:28 Executing step: remValuesEAPPS
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:30 (ossystem.cpp (96) err=255 sys=0) SBL-GEN-00255: Internal: Error during exec()
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:30 Step remValuesEAPPS: failed to run program cmd with cmdline /C del %%SiebelRoot%%%%OSDirSeparator%%bin%%OSDirSeparator%%eapps.cfg
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:30 Executing step: remValuesLDAPkeyfile
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:32 (ossystem.cpp (96) err=255 sys=0) SBL-GEN-00255: Internal: Error during exec()
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:32 Step remValuesLDAPkeyfile: failed to run program cmd with cmdline /C del %%SiebelRoot%%%%OSDirSeparator%%admin%%OSDirSeparator%%ldapkey.kdb
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:32 Executing step: remValueslb
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:34 (ossystem.cpp (96) err=255 sys=0) SBL-GEN-00255: Internal: Error during exec()
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:42:34 Step remValueslb: failed to run program cmd with cmdline /C del %%SiebelRoot%%%%OSDirSeparator%%admin%%OSDirSeparator%%lbconfig.txt
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:00 Error in transferring input values ,num of arrays incorrect 0, expected : 1

GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:00 TransferInputsToValues returned error:3611539 to SetControlValues
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:02 Executing step: ConfigMode
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:02 Executing step: MainTask
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:02 Executing step: MainTaskCreate
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:02 Executing step: SWSERoot
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:02 Executing step: GatewayUseDefaultRead
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:02 Executing step: GatewayCreateDefaultRead
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:02 Executing step: AdminUser
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:02 Executing step: AdminPassword
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:02 Executing step: InputSWSEServerName
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:02 Executing step: TRACELEVELDEFAULT
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:02 Executing step: DeployedLanguage
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:02 Executing step: SiebelRootUnix
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:02 Executing step: DoubleQuote
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:02 Executing step: GatewayAddress
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:02 Executing step: EnterpriseServer
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:02 Executing step: RequestComponent
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:02 Executing step: RequestServer
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:02 Executing step: LoadBalancerOption
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:02 Executing step: AppServerHostName
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:02 Executing step: SCBPort
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:02 Executing step: EnableVirtualHosts
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:02 Executing step: LoadBalancingServer
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:02 Executing step: eappscfgExists
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:02 Executing step: eappscfgExists
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:02 Executing step: WebServerInstance
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:02 Executing step: WriteWebServerInstance
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:04 Executing step: ApplyValuescfg
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:04 Executing step: ApplyValuescfgSIA
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:04 Executing step: RestartWebServer
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:04 Executing step: SetMimeTypes
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:06 Step SetMimeTypes: failed to run program %%SiebelRoot%%%%OSDirSeparator%%install_script%%OSDirSeparator%%install%%OSDirSeparator%%UpdateMimeTypes with cmdline %%SiebelRoot%% %%WebServerInstance%%
GenericLog GenericError 1 000000024908205d:0 2008-10-29 16:44:06 Failed during Execution, err: 5500044


Can you help me?

P.S: when applying configuration i didn't checked restart web server and web server is shut down .

Best Reguards,
Sorokin Stanislav.

Edited by: user10487968 on 29.10.2008 8:07

Edited by: user10487968 on 30.10.2008 1:04
  • 1. Re: Can't apply SWSE config profile
    664562 Explorer
    Currently Being Moderated
    Hi,

    here is a case study hope this will help you to solve your problem.


    Symptoms
    SBL-STJ-00152

    I am getting an error when configuring SWSE. I am runing the script from ksh. Please suggest.

    Thanks,


    Solution
    Message 1
    Customer had placed the SWESE Logical Profile in a directory with dash characters.
    While configuring the Web Server Extention, the error SBL-STJ-00152 appears in ghraphical wizard.

    The following error is received in the log file:

    /local/apps/siebel/websrv-80-poc-profile/websrv-80-poc-profile does not exist. Please create the path or choose an existing path.
    ..
    GenericLog GenericError 1 0000000346c42960:0 2007-08-16 16:48:50 Failed during Execution, err: 5500044

    Resolution:
    Dash is not a valid character for directory name. This is noted in the Siebel Installation Guide for UNIX > Installing Siebel Enterprise Server and Related Components :

    "NOTE: The directory name must use standard alphanumeric characters, including the underscore. No other characters or spaces are allowed."

    After placing it in a directory without dashes it worked fine.

    Regards,
    Neeraj Verma

    Edited by: Neeraj Verma on 29-Oct-2008 23:18
  • 2. Re: Can't apply SWSE config profile
    667711 Newbie
    Currently Being Moderated
    Ok thanks i'm try it ....

    Edited by: user10487968 on 30.10.2008 0:51
  • 3. Re: Can't apply SWSE config profile
    667711 Newbie
    Currently Being Moderated
    Sorry but i use standart symbols, my dir is \opt\SBA80\sweapp
    and my profile path is \opt\SBA80\sweapp\admin\Webserver

    Edited by: user10487968 on 30.10.2008 0:55

    Edited by: user10487968 on 30.10.2008 0:58
  • 4. Re: Can't apply SWSE config profile
    664562 Explorer
    Currently Being Moderated
    Hi,

    Userid used to install and configure the swse is not the same as userid who own the webserver.

    use the same userid as the owner of the webserver to reinstall and reconfigure the swse, it will completed successfully.

    Ensure that owner of the swse is the same as owner of webserver, or ensure that owner of the swse has full access to the webserver directory and it's subfolder.

    I hope this may be your problem

    Regards,
    Neeraj Verma
  • 5. Re: Can't apply SWSE config profile
    667711 Newbie
    Currently Being Moderated
    All installation hase been created by user root.
  • 6. Re: Can't apply SWSE config profile
    664562 Explorer
    Currently Being Moderated
    Does all the things are working fine now?
  • 7. Re: Can't apply SWSE config profile
    667711 Newbie
    Currently Being Moderated
    No ,in SWSE can't apply configuration, but other components are worked perfect!
  • 8. Re: Can't apply SWSE config profile
    664562 Explorer
    Currently Being Moderated
    Did you reconfigured swse ?

    and used same userid as webserver owner.

    also ensure that owner of the swse has full access to the webserver directory and it's subfolder

    Neeraj
  • 9. Re: Can't apply SWSE config profile
    667711 Newbie
    Currently Being Moderated
    all component installing and configured by root user, it means that it have all permission in all directorys !
  • 10. Re: Can't apply SWSE config profile
    664562 Explorer
    Currently Being Moderated
    when prompted for the “Web Server Instance Location" during the SWSE configuration what is the actual location do you give
    please give me the location address which you used wihile configuring

    and also give me the deatils about the parameters you used while configuring swse

    and let me know which version are you installing?

    Neeraj
  • 11. Re: Can't apply SWSE config profile
    667711 Newbie
    Currently Being Moderated
    Hi ! Thank for waiting,
    Information about web server:

    Sun Java System Web Server 7.0U3

    PRODUCT_SP_VERSION=3
    PRODUCT_FULL_VERSION=7.0U3
    JDK_LOCATION=/usr/webserver7/jdk
    INSTALLED_COMPONENTS=svrcore,svrcore64,admincli,devsupport,langpack
    PRODUCT_VERSION=7.0

    Istallation Path:
    /usr/Webserver7

    Path to apply web server in SWSE configuratoin

    /usr/Webserver7/https-siebel-web (where siebel-web is name of my web server)

    Configuration of SWSE:


    The Siebel Configuration Wizard will execute using the following settings:

    MainTask : Create
    Load Balancing Configuration : Single Siebel Server
    Application Server Host Name : siebel-app.mosenergosbyt.ru
    Siebel Connection Broker Port : 2321
    Siebel Web Server Extension Logical Profile Location : /opt/Webserver
    Web Server Instance Location : usr/webserver7/https-siebel-web/
    RestartWebServer : false
    EVTWelcome : Configuration Wizard Hint: Siebel Bookshelf provides searchable
    documentation. For EVT command-line help run evt -? or EVT -h.

    Press 1 for Next, 2 for Previous, 3 to Cancel or 4 to Redisplay [1]

    1. Yes
    2. No

    Do you want to execute configuration? [2] 1

    Execution Failed!

    Edited by: Stanislav_Sorokin on 31.10.2008 2:09
  • 12. Re: Can't apply SWSE config profile
    599764 Journeyer
    Currently Being Moderated
    That is a unsupported Web Server I think. Have a look at:

    Supported Web Servers (Page 39 and 40) in

    http://download.oracle.com/docs/cd/E11886_01/V8/CORE/8_0_Reqs_Platform_RevG.pdf

    Found here:

    Siebel System Requirements and Supported Platforms

    http://download.oracle.com/docs/cd/E11886_01/srsphomepage.html

    Supported are:

    1) Microsoft IIS 6.0 or above
    2) Sun Java System Web Server 6.1 (SPARC-based), SP4 or above
    ...

    I would ask Oracle if 6.1 SP4 and above includes 7.0U3

    Axel
  • 13. Re: Can't apply SWSE config profile
    667711 Newbie
    Currently Being Moderated
    ver 7.0 is above ver 6.1 =)
  • 14. Re: Can't apply SWSE config profile
    664562 Explorer
    Currently Being Moderated
    Hi,

    I dont know sun java version 7.003 is supported with siebel 8.0 or not (i think it may be supported)

    but first change the name of your name of your webservr from siebel-web to siebelweb

    and reconfigure swse with the options


    MainTask : Create
    Load Balancing Configuration : Single Siebel Server
    Application Server Host Name : siebel-app.mosenergosbyt.ru
    Siebel Connection Broker Port : 2321
    Siebel Web Server Extension Logical Profile Location : /opt/Webserver
    Web Server Instance Location : usr/webserver7/https-siebelweb/
    RestartWebServer : true


    and tell does it works


    Neeraj
1 2 Previous Next

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points