0 Replies Latest reply: May 23, 2008 10:28 AM by 666705 RSS

    Our WAR deploys Admin Server but not Managed Server

    666705
      We are testing our Spring application on WebLogic Server 10.0 MP1, however we are only able to run our application to the Admin Server in our Domain and not a managed server. We can deploy the WAR on both but when we try and start it up on a Managed Server it fails as it can not find a Spring property file, however we do not have this issues when we start our application under the admin server. The error message is:

      ####<23-May-2008 16:04:58 o'clock BST> <Warning> <HTTP> <LGN-PD-APP-01> <WLTEST-Server-0> <[ACTIVE] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <> <1211555098699> <BEA-101162> <User defined listener com.lagan.lagancentre.core.springsupport.LaganContextLoaderListener failed: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'serviceResourceBundle' defined in ServletContext resource [WEB-INF/applicationContext.xml]: Instantiation of bean failed; nested exception is org.springframework.beans.factory.BeanDefinitionStoreException: Factory method [public static final java.util.ResourceBundle java.util.ResourceBundle.getBundle(java.lang.String)] threw exception; nested exception is java.util.MissingResourceException: Can't find bundle for base name services, locale en_GB.
      org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'serviceResourceBundle' defined in ServletContext resource [WEB-INF/applicationContext.xml]: Instantiation of bean failed; nested exception is org.springframework.beans.factory.BeanDefinitionStoreException: Factory method [public static final java.util.ResourceBundle java.util.ResourceBundle.getBundle(java.lang.String)] threw exception; nested exception is java.util.MissingResourceException: Can't find bundle for base name services, locale en_GB

      Any one have any ideas why this might be the case?