This discussion is archived
1 Reply Latest reply: Jul 9, 2008 6:02 PM by 3004 RSS

Could not perform unpadding: invalid pad byte.

666705 Newbie
Currently Being Moderated
Hello All

In my config file I have 2 references to connection pool files.. In the files I have the following tag.

<password-encrypted>{3DES}I8OqBHafh35fn6iVd6YXxw==</password-encrypted>


When I try to run my connection pools are not getting initalized and the following error is displayed

Could not perform unpadding: invalid pad byte.

From my limitied knowledge I would just liek to change this to clear text or reencrypt the password. Can anyone help or send a link to an article that would help?

I am running weblogic 9.2

Thanks
  • 1. Re: Could not perform unpadding: invalid pad byte.
    3004 Newbie
    Currently Being Moderated
    You can use the encrypt utility to reencrypt the password.

    http://edocs.bea.com/wls/docs90/admin_ref/utils.html#1209592

    D Walt wrote:
    Hello All

    In my config file I have 2 references to connection pool files.. In the files I have the following tag.

    <password-encrypted>{3DES}I8OqBHafh35fn6iVd6YXxw==</password-encrypted>


    When I try to run my connection pools are not getting initalized and the following error is displayed

    Could not perform unpadding: invalid pad byte.

    From my limitied knowledge I would just liek to change this to clear text or reencrypt the password. Can anyone help or send a link to an article that would help?

    I am running weblogic 9.2

    Thanks