3 Replies Latest reply: Jun 30, 2008 5:23 PM by 666705 RSS

    Issue validating ALDSP3.2 from command line using java cmd or ANT script

    666705
      Hi,
      I am having difficulty in validating ALDSP 3.2 Project , when I run it through the cmdline_build.xml(ANT Script) available in <bea_home>/aldsp32/bin folder.

      I created a property for workspace , eclipse home pointing to beahome\tools\eclipse32\eclipse

      The first ant target runs fine validating the workspace , eclipse home.

      Ant help fails
      C:\bea10\aldsp_3.2\bin>ant help
      Buildfile: build.xml

      check-eclipse-home:

      help:

      BUILD FAILED
      C:\bea10\aldsp_3.2\bin\build.xml:64: Java returned: 13

      Total time: 6 seconds

      Ant validate-project fails

      Same happens when I try to run validate-project as well in the build file , I also pointed the jar file in the aldsphome\eclipse-plugins\dsp\eclipse\plugins\com.bea.dsp.ide.app_3.2.0.jar which is used in the target(validate-project) as a argument to validate the ALDSP3.2 projects. (Ref as arg classname :- com.bea.dsp.ide.app.Activator) It fails stating

      Buildfile: build.xml

      check-workspace:

      check-eclipse-home:

      init:
      [echo] ECLIPSE_HOME location is C:/bea10/tools/eclipse32/eclipse
      [echo] Eclipse workspace location is C:/data_services/solution/src/DataFabr
      ic32/Claims/ClaimsDataSpace

      validate-project:

      BUILD FAILED
      C:\bea10\aldsp_3.2\bin\build.xml:79: Java returned: 13Have anyone seen an error like this one, I tried to browse around for documents & found only ALDSP3.0 docs for validating ALDSP project from ant scripts or java command.

      I have same issue when I try to run in command line through java command as well same error code : 13 is returned.

      I tried to use both jrockit jdk & sun jdk implementation with weblogic 10.0 M1 but my efforts are in vain.

      Any suggestions or workarounds?
        • 1. Re: Issue validating ALDSP3.2 from command line using java cmd or ANT script
          666705
          Do i have to start the server to validate the dsp project?

          --
          Edited by karthik.prabu@gmail.com at 06/27/2008 8:05 AM
          • 2. Re: Issue validating ALDSP3.2 from command line using java cmd or ANT script
            666705
            Have you tried running ant with the verbose flag? Check the ant documentation.

            Have you tried looking at line 64 in build.xml ?
            • 3. Re: Issue validating ALDSP3.2 from command line using java cmd or ANT script
              666705
              I changed the eclpse home to point to

              C:\bea10\tools\eclipse_pkgs\1.1\eclipse_3.2.2\eclipse instead of
              C:\bea10\tools\eclipse32\eclipse.

              1.ant help - worked fine.
              2.ant validate-project - still fails with same error.

              I tried with command ant -verbose validate-project & as well
              ant -debug validate-project it fails.

              I noticed com.bea.dsp.ide.app.Activator was not part of start.jar so i added the classpath of com.bea.dsp.ide.app_3.2.0.jar available in plugins in dsp.

              I am attaching the trace.log of verbose output.

              I am not sure if something is wrong from my end.

              This is how it looks in ant file

              <target name="validate-project"
              description="Validates the specified dataspace project."
              depends="init">
              <java classname="org.eclipse.core.launcher.Main" fork="true" failonerror="true" maxmemory="256m">
              <classpath>
              <pathelement location="${ECLIPSE_HOME}/startup.jar"/>
              <pathelement location="${ECLIPSE_HOME}/com.bea.dsp.ide.app_3.2.0.jar"/>
              </classpath>
              <arg value="-data"/>
              <arg value="${workspace}"/>
              <arg value="-application"/>
              <arg value="com.bea.dsp.ide.app.Activator"/>
              <arg value="validate-project"/>
              <arg value="${project}"/>
              </java>
              </target>

              Please let me know if you figure out somethign wrong with my approach.