6 Replies Latest reply: Jun 5, 2009 5:09 AM by nww RSS

    Automating a business rule (HBR)

    671344
      Hi,

      I'm trying to launch a Business Rule using the CmdLnLauncher.exe but what ever I do, I keep recieving the following error message :
      "Launcher is unable to create a valid session. Batch process will terminate".

      I tried using several syntaxes for the batch, but whatever syntax I use, I'm always getting the same message.

      Here are the different syntaxes I've tried so far:
      - cmdlnlauncher /Sserver /Uuser /Ppassword /Aapplication /Ddatabase /RRulename /FRule.rtp
      - call cmdlnlauncher.exe /Sserver /Uuser /Ppassword /Aapplication /Ddatabase /RRulename /FRule.rtp

      Local.rtp contains the prompt values for the Rule, file created using HBR.
      I tried using "-S" instead of "/S" but it doesn't recognize the server name in this case. I guess it's the difference between using Windows and Unix systems.

      I'm using Planning version 3.51
      Moreover, is it possible to launch using this same command a sequence?

      If anyone has an idea, it would greatly be appreciated. Thanks
      Jerome

      Edited by: user10418977 on 19 nov. 2008 07:47