This discussion is archived
4 Replies Latest reply: Nov 30, 2008 11:45 PM by user477000 RSS

Error on XE

user477000 Explorer
Currently Being Moderated
Hi, I'm working on .NET Stored Procedure.
I use VS 2008. with ODT 11.1.06.20 I deployed it to local 11g DB it worked fine.
I need this on XE wich is a target platform for this solution, unfortunately when I deployed it (successfully) from VS to remote DB and tried to test it I got error:

ERROR at line 1:
ORA-20100: Invalid number of parameters.
ORA-06512: at "SYS.DBMS_CLR", line 234
ORA-06512: at "MYPACKAGE.MYFUNCTION", line 6

It's parameter-less function returning Varchar2 with security type UNSAFE.

It seems like differences in package DBMS_CLR between those two releases.

Any advices?

Edited by: user477000 on Nov 20, 2008 12:51 AM
  • 1. Re: Error on XE
    502182 Explorer
    Currently Being Moderated
    You will have to use Oracle Developer Tools for Visual Studio (ODT) for XE. However that does not support developing .NET stored procedures other than from VS2003. Not sure if that is an option for you.
  • 2. Re: Error on XE
    user477000 Explorer
    Currently Being Moderated
    Thanks skj,
    I'll have to check it with my client and then against my MSDN subscription.

    I was wondering if those things are part of any doc for XE or ODT? I could not find any of those informations.
  • 3. Re: Error on XE
    502182 Explorer
    Currently Being Moderated
    You may download ODT for XE from http://www.oracle.com/technology/software/tech/dotnet/odtxedownloads.html
  • 4. Re: Error on XE
    user477000 Explorer
    Currently Being Moderated
    Thanks, it was very helpful again.

    It's scary too, Is it the only version that works with XE?
    First line of Known issues is :
    "Visual Studio .NET 2005/2002 not supported in this release

    This release will not work properly with Visual Studio 2005 nor with Visual Studio .NET 2002. Please note: support or Visual Studio 2005 will be included in an upcoming release."
    Has nothing been changed in those last 3 years?

    It looks like now it requires XE installation. I have 11g installed on my laptop and I'd prefer not to remove it. Is there any possibility to keep it and work with this version of client or should You into "virtualization" to proceed with it?

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points