This discussion is archived
3 Replies Latest reply: Jan 26, 2009 11:41 AM by Hussein Sawwan-Oracle RSS

Unable to resolve gap in redo logs

669842 Newbie
Currently Being Moderated
Hi,

This morning we noticed that there was a gap in the application of our logs. The following steps were performed in an attempt to resolve the error:

1. Noticed that gaps were not being applied on the standby server.
2. Ran "SELECT * FROM V$ARCHIVE_GAP;" on the standby server to ascertain where the gap exists. Result was 111378.
3. Ran "SELECT NAME FROM V$ARCHIVED_LOG WHERE THREAD#=1 AND DEST_ID=1 AND SEQUENCE# BETWEEN 111378 AND 111378;" on the primary server to ascertain the location of the logfile. The result was "/u03/erpm/ARCH/1_111378_657937029.dbf".
4. Checked the standby server to ensure that file did not exist. Found that file was indeed there. Tried to register the logfile using the command 'ALTER DATABASE REGISTER LOGFILE '/u03/erpm/ARCH/1_111378_657937029.dbf'; Encounter ORA-00317 error.
5. Decided to copy the file from primary to standby and register. Backed up the file on standby, then copied from primary. Verified that correct permissions and ownership was set.
6. Again tried to register using the command in step 4 but again encountered ORA-00317.


I don't understand why it's rejecting the logfile when it's pointing me there in the first place. Does anyone have a clue as to how I can resolve this problem please? We are currently running EBS 11.5.10.2 and DB 10.2.0.4 on RHEL 4.0. Any assistance would be much appreciated.

.P.S. This is our LIVE system.

Lia.

Edited by: Lia on Jan 26, 2009 2:29 PM

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points