3 Replies Latest reply: Apr 14, 2009 5:04 AM by Turribeach RSS

    obiee oci driver loading problem

    575729
      hi,

      I have oracle 11g client at one home. username oracle with group oinstall

      I have to install obiee in a second home name obiee user. I have create the repository successfully now when query i get the following error

      State: HY000. Code: 0. [NQODBC] [SQL_STATE: HY000] [nQSError: 10058] A general error has occurred. ld.so.1: nqsserver: fatal: libclntsh.so.10.1: open failed: No such file or directory [nQSError: 46029] Failed to load the DLL /u02/software/OracleBI/server/Bin64/libnqsdbgatewayoci10g64.so. Check if 'Oracle OCI 10G' database client is installed. (HY000)

      i have specified the LD_LIBRARY_PATH the database $ORACLE_HOME/lib directory but still no luck kindly help

      regards
      Nick
        • 1. Re: obiee oci driver loading problem
          Turribeach
          Have you tried using the Forum Search option? Searching for libclntsh.so.10.1 will get you a lot of useful posts, [this one|http://forums.oracle.com/forums/thread.jspa?threadID=845201&tstart=0&messageID=3337566#3337566] is a sample.
          • 2. Re: obiee oci driver loading problem
            575729
            OK let's start again with all you need to do as you don't clarify if you have done it or not:

            1) Make sure you got a full Oracle 10g client installed (check with your DBA).
            2) Make sure your Oracle 10g client has the OCI 32bits libraries installed (check in the ORACLE_HOME/lib32 directory that the libclntsh.so.10.1 library exists and it's size is bigger than 0 bytes).
            3) Configure your OBIEE user.sh file to make sure your ORACLE_HOME and TNS_ADMIN variables are correctly set. You also need to set these two:

            export PATH=$ORACLE_HOME/bin:$PATH
            export LD_LIBRARY_PATH=$ORACLE_HOME/lib32:$LD_LIBRARY_PATH

            4) Restart all your OBIEE services and check that all variables are correctly set (type "env").

            After you have done all that give it a test and let us know if it works.

            gr8.
            ---------------------------
            I have oracle client installed.
            i have ORACLE_HOME/lib32 in my bi home .profile
            but its still not working

            I think i have to find the user.sh script where can i find it

            regards
            Nick
            • 3. Re: obiee oci driver loading problem
              Turribeach
              Check [this thread|http://forums.oracle.com/forums/thread.jspa?messageID=3248206#3248206] and confirm whether you have read and done all the checks that are mentioned on the two threads I suggested.