0 Replies Latest reply: Apr 16, 2009 12:24 PM by 679308 RSS

    Cannot get a simple ESI example working

    679308
      I have a clean CentOS5 server. The httpd server is starter on port 80.

      I installed webcache which defaulted to port 7780

      in the docroot, here is index.html
      <body>
      <html>
      <H1> TEST START< /H1>
      <esi:include src="middle.html"/>
      <H1> TEST END</H1>
      </html>
      </body>

      in the docroot, here is middle.html
      <body>
      <html>
      <H1>ESI TEST MIDDLE</H1>
      </html>
      </body>

      going to http://127.0.0.1:7780/index.html I get:
      TEST START
      TEST END

      viewing the source I see:
      <body>
      <html>
      <H1> TEST START</H1>
      <esi:include src="middle.html"/>
      <H1> TEST END</H1>
      </html>
      </body>

      so that means to me that the ESI tag is not being processed. I've been poking around the webcache admin looking at the "ESI Propagation Policy Association" page as well as the "Caching, Personalization, and Compression Rules" page, but none of the options seems to have an effect.

      This has got to be a simple problem. I read about the surrogate-control, but I don't see why that's relevant.