0 Replies Latest reply: May 6, 2009 1:53 AM by 35422 RSS

    FTP adapter produces wrong XML after adding new attribute

      I have an InterConnect scenario with two adapters - a DB-adapter which publishes messages and an (XML-type) FTP-adapter subscribing to these messages and produces XML-files in a directory.

      This basic setup works well - but now I have added a new attribute to the message by adding it to the DB-adapter App. Data Type and I have added it to the Common Data Type and I have mapped the two using CopyField.
      Similarly I have the new field the App. Data Type in the FTP-adapter - again mapping the new field from the Common Data Type to the App. Data Type using CopyField.

      Now, when sending a message and inspecting the log files I can see, that the mapping from the DB-adapter to the hub CDT and on to the FTP-adapter is correct - my new attribute (called T0068) is mapped as I intended and contains the correct value "DK-BT-004-003" - however the resulting XML-file is not correct.

      Snippet from the FTP-adapter log file:

      Message from hub:

      <AO N = "IGVersion">
      <A N = "S009_0065">UTILMD</A>
      <A N = "S009_0052">D</A>
      <A N = "S009_0054">02A</A>
      <A N = "S009_0051">UN</A>
      <A N = "S009_0057">DKGAS1</A>
      <A N = "T0068">DK-BT-004-003</A>
      <A N = "PCDATA">293237</A>

      Ergo, my new attribute T0068 contains the correct value.
      The FTP-adapter produces:

      Source Fields: [Send_CO:OAI/V1.UTILMD.UtilmdHeader]
      Destination Fields: [UTILMDE07_Send_OAI_V1_S:OAI/V1.UTILMD.UtilmdHeader]
      Source values: [  IGVersion
      S009_0065: UTILMD
      S009_0052: D
      S009_0054: 02A
      S009_0051: UN
      S009_0057: DKGAS1
      T0068: DK-BT-004-003
      PCDATA: 293237

      Thus, the value is mapped correctly to the FTP-adapter App. Data Type.

      The result is the following (only a partial XML-file):

      <IGVersion S009_0065="UTILMD" S009_0052="D" S009_0054="02A" S009_0051="UN" S009_0057="DKGAS1">DK-BT-004-003293237</IGVersion>

      And should have been:

      <IGVersion S009_0065="UTILMD" S009_0052="D" S009_0054="02A" S009_0051="UN" S009_0057="DKGAS1" T0068="DK-BT-004-003">293237</IGVersion>

      Somehow the content of new attribute T0068 is added the content of my PCDATA attribute instead becoming an actual attribute in the XML-tag.

      I have of course pushed metadata and restarted both my adapters several times in order to make this work as I intend it to.

      The puzzle is: Why does the FTP-adapter produce an XML-file which does not correspond to the mapping shown in the adapter log file?

      Kind regards,

      - Tom