0 Replies Latest reply on May 21, 2009 11:07 PM by NN

    Help on Setting up Web Cache.


      I need help for setting up OAS Web Cache, whether the following setup is correct. I’m new to this.
      When I login to http://server2.domain.com:8300/appname1/, the display URL is changed to http://server2.domain.com:7778/appname1/. However there is no activity in the Web Cache Statistics.

      We have OAS Web Cache standalone installed on one server using port 80 (e.g. server1.domain.com) and OAS Application Server (HTTP & J2EE) installed on another server using port 7777 (e.g. server2.domain.com).

      Currently, when our user login to the application, they use the following URLs:

      I have setup OAS Web Cache as follows:

      Listen Ports:
           Cache Name: server1.domain.com-WebCache
           IP Address: ANY
           Port: 7778

      Origin Servers:
           Host: server2.domain.com
           Port: 7778
           Routing: enabled
           Ping URL: /
           Protocol: HTTP

      Site definitions (two entries)
           Hostname: server1.domain.com
           Port: 80
           URL Path Prefix: (blank)
           Default: No
           Aliases (Host Name: None, Port: N/A, URL Path Prefix: N/A)

           Hostname: server2.domain.com
           Port: 7778
           URL Path Prefix: /
           Default: No
           Aliases (Host Name: None, Port: N/A, URL Path Prefix: N/A)

      Site to Server Mapping:
           Site                    Origin Server     
      Priority Host Name     Port URL Path Prefix ESI Content Policy Host Name     Port
      1 server2.domain.com 8300 /appname1/ Unrestricted      server2.domain.com     7778
      2 server2.domain.com 19000 /appname2/ Unrestricted      server2.domain.com     7778
      3 server2.domain.com 7777 Unrestricted      server2.domain.com     7778
      4     *      7777 Exclude Fragments server2.domain.com     7778
      5     *      *           Exclude Fragments server2.domain.com     7778

      And in server2.domain.com, the following has been set in httpd.conf

      ServerName server2.domain.com
      UseCanonicalName On

      Port 7777
      Listen 7777
      Listen 7778
      Listen 19000

      <VirtualHost server2.domain.com:8300>
           Port 7778

      Any advise is appreciated.