7 Replies Latest reply: Jul 24, 2013 8:51 AM by f2b2f18e-f3c1-4e74-828b-4a6d074a97df RSS

    How to set ORACLE_HOME used by SQL Developer?

    220870
      I need to use OCI/Thick driver with SQL Developer to get OS authentication working. I have 64-bit windows and 64-bit oracle installed. I also have 32-bit instant client in another ORACLE_HOME, because the libs of 64-bit ORACLE_HOME won't work with SQL Developer. Quite trivial setup if the SQL Developer would just take the hint an start using the right ORACLE_HOME. I have tried making a start.bat containing following...

      set ORACLE_HOME=C:\oracle\product\11.1.0\instantclient_11_1
      start sqldeveloper.exe

      ..but it doesn't have any effect. I can't change ORACLE_HOME in registry, because it would mess up other services requiring 64-bit oracle.