7 Replies Latest reply: Jun 29, 2009 2:52 AM by Shankar S.-Oracle RSS

    PSLSINV AW Not being created by AWM...


      I am trying to close my installation on ORDM. I have already installed everything, but the OLAP option is not working properly. OBIEE with all the reports work perfectly now
      with some minor bugs...the OLAP dashboards no!

      I have database + OLAP B Patch, AWM is the one that comes with the Oracle Client zip file (is this the correct final version already??). I was trying to find a patch number 6368282 from My Oracle Support (according to the installation guide) but it doesn't exist to Linux.

      AWM cannot import from template the PSLSINV.M10.XML.... giving what it looks like a parsing error. Looks like version problems..

      Looking at my DB:
      select * from dba_registry
      where comp_name like '%OLAP%'

      APS     OLAP Analytic Workspace     VALID
      XOQ     Oracle OLAP API     VALID
      AMD     OLAP Catalog     VALID

      Can u provide some advice on this since the guide is not clear about it?
      I have a Linux 32x64 for my testings.

      Thank you.

      Alvaro Silva

      Edited by: AlvaroSilva on Jun 7, 2009 2:48 AM
        • 1. Re: PSLSINV AW Not being created by AWM...
          Answer to my question...
          I kept the previous values!

          I have passed the error my "programatically" created the AW. Then opened the AWM for bia_rtl_olap.

          The correspondent code, for programatically creation, exists inside the sql's in sample directoy for 11g.
          grep it..

          For now I opened OBIEE, OLAP dashboard.... but no data available.
          Have to check why!

          • 2. Re: PSLSINV AW Not being created by AWM...
            Shankar S.-Oracle
            Hi Alvaro,

            I'm assuming that you're installing the sample schema of ORDM.
            From your mails, it seems that you have progressed to the stage that the relational reports are showing data but the OLAP Dashboard is not working.

            Some points to note/check at your end regarding the installation:
            a) AWM (patch 6368282) is only available for Windows env. It is possible to administer the olap schema/aw on linux OS using AWM from a client machine/laptop. However this is not essential for the purpose of installing the product. It can help in debugging/checking the install for specific objects in the aw etc.
            b) Is this a 64 bit linux machine? If you're installing the sample schema, then relational and mining schema are installed by default (the installer does it). The olap schema needs to be created by calling a specific script. Sample data installed by script "ordm_olap_11g_install_scr.sql". Can you confirm that the script was invoked post install and that it did not report any errors.
            c) Please copy paste any parse errors and/or script debugging output to help diagnose this further.

            You can email me at shankar (dot) somayajula (at) oracle (dot) com to see how we can resolve the install issue faster.

            • 3. Re: PSLSINV AW Not being created by AWM...
              Shankar S.-Oracle
              Some more info required regarding install/config choices -
              a) What are the choices given during calendar set up (in the ORDM Installation UI)?
              b) What were the inputs given while calling the install scripts (Historical Star/End dates input parameters)?

              • 4. Re: PSLSINV AW Not being created by AWM...
                Hi Shankar. Thank you for the reply and help.

                At this moment I upgraded DB to Everything is coherent with this version and the guide.

                Almost everything is running well, but for now OLAP is not working inside OBIEE/dashboards. Well, no data is obtained...

                Opening AWM and trying to get data for the 4 cubes I get errors... I believe that this has to do with name lenghts... ORA:00972 identifier is too long.. ERROR CLASS:OLAPI
                Is this a OLAP option bug?

                To refer that I have upgraded from to and followed the steps of the Database upgrade...

                Regarding dates for samples I have used everything like the installation guide shows. The intervals are the ones described.

                By the way, where can I find further documentation on RDM? Data model PDF or any other user guide?

                If you prefer I will contact you by email.

                Thank you again.

                Alvaro Silva
                • 5. Re: PSLSINV AW Not being created by AWM...
                  Shankar S.-Oracle
                  I dont know if you tried running the scripts and installing the olap AW once again after upgrading from to I'm not sure that the old AW would work in as is (with just the database upgraded). Its recommended to make a fresh start in since the AW XML template defining the AW is different between the two versions.

                  You can contact me offline regd this.

                  • 6. Re: PSLSINV AW Not being created by AWM...
                    Hi. Thanks for the reply!

                    And ... sorry for the delay on answering, but almost everything is running ok now. [95%]

                    I just like to know how long takes the incremental load for the sample included (OLAP).

                    It ran the HISTORICAL part in 1.30 hour.

                    It is still running the OLAP Verification check 1 already for 9 hours.

                    I Know I am using a VM for testing purposes, so I don't know if it's feasible to work with the OLAP option with just 2mb of VM ram
                    to test this ORDM OLAP part sample.

                    Is it possible to improve this timings? Is it still normal to take so long building the OLAP cubes?

                    Thank you.

                    Álvaro Silva
                    • 7. Re: PSLSINV AW Not being created by AWM...
                      Shankar S.-Oracle

                      If you're using the sample schema/examples, the default script runs both loads based on the standard date ranges.

                      Typical timings on 11g are:
                      Historical load (3 years+ date range) - ~30 min
                      Incremental Load (2 year+ date range) - ~20 min

                      If the query (check1) is taking more than 9 hours then something is definitely wrong.
                      I dont think using a 2Mb ram machine is suitable for testing Oracle OLAP. They tend to be a bit memory intensive.

                      Dont know if this helps since you seem to have made up your mind.